summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/fan-policy.bb
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2019-06-12 21:01:04 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-27 23:22:43 +0300
commitf14cc1b38d12e658dbbb4102452e11a1de9ab6d6 (patch)
treeec780c7957466b07da686eeb63d48f41669439f6 /meta-ibm/meta-witherspoon/recipes-phosphor/dbus/fan-policy.bb
parentee6efccdcb19807a141c5c2d93c3f6bfe8f8fc4c (diff)
downloadopenbmc-f14cc1b38d12e658dbbb4102452e11a1de9ab6d6.tar.xz
Put dbus monitor policies in one place
To better organize the policies(and the configurations) that are used by phosphor-dbus-monitor, all of them are now located under the `dbus` directory. This moves toward a more understandable and centralized scheme for the recipe(s) used to configure and build phosphor-dbus-monitor. (From meta-ibm rev: 4b80c4f2b3a62d8084fc43f95177e299d53387ae) Change-Id: Ie99c5dbe55c2295fc5cd7b5e7722cc10064e1b71 Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor/dbus/fan-policy.bb')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/dbus/fan-policy.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/fan-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/fan-policy.bb
new file mode 100644
index 000000000..12194640d
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/fan-policy.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Fan policy configurations for meta-witherspoon machines"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-dbus-monitor
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI += "file://air-cooled.yaml"
+SRC_URI += "file://water-cooled.yaml"
+SRC_URI += "file://fan-errors.yaml"
+
+do_install() {
+ install -D ${WORKDIR}/air-cooled.yaml ${D}${config_dir}/air-cooled.yaml
+ install -D ${WORKDIR}/water-cooled.yaml ${D}${config_dir}/water-cooled.yaml
+ install -D ${WORKDIR}/fan-errors.yaml ${D}${config_dir}/fan-errors.yaml
+}
+
+FILES_${PN} += "${config_dir}/air-cooled.yaml"
+FILES_${PN} += "${config_dir}/water-cooled.yaml"
+FILES_${PN} += "${config_dir}/fan-errors.yaml"