summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/power
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:17:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-02 16:19:25 +0300
commite83c22094b7e4970c96bcee273ab08d05bbc0a30 (patch)
tree80cb87a34afb07b7d375b534bb5df68468c2b5a6 /meta-ibm/recipes-phosphor/power
parentd97cf9b9ef84cdad2f357164e36b76619e7dc379 (diff)
downloadopenbmc-e83c22094b7e4970c96bcee273ab08d05bbc0a30.tar.xz
meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override syntax, including the SYSTEMD_ variables. Change our systemd.bbclass to do the same for consistency and perform a tree-wide variable replacement. Spot checked by building bletchley and witherspoon and checking some of the SYSTEMD_LINK directives on installed packages under qemu. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
Diffstat (limited to 'meta-ibm/recipes-phosphor/power')
-rw-r--r--meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend2
-rw-r--r--meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend b/meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend
index 9acaad768..c8d6a4617 100644
--- a/meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend
+++ b/meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend
@@ -21,4 +21,4 @@ do_install:append(){
FILES:${PN} += "${datadir}/phosphor-power/psu.json"
PSU_MONITOR_ENV_FMT = "obmc/power-supply-monitor/power-supply-monitor-{0}.conf"
-SYSTEMD_ENVIRONMENT_FILE_${PN}-monitor:append:ibm-ac-server += "${@compose_list(d, 'PSU_MONITOR_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}-monitor:append:ibm-ac-server += "${@compose_list(d, 'PSU_MONITOR_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
diff --git a/meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb b/meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb
index 4c4c88401..74bb9a0c5 100644
--- a/meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb
+++ b/meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb
@@ -13,4 +13,4 @@ TGTFMT = "obmc-chassis-poweron@0.target"
SYNC_FMT = "../${SYNC_SERVICE}:${TGTFMT}.wants/${SYNC_SERVICE}"
SYSTEMD_SERVICE:${PN} += "${SYNC_SERVICE}"
-SYSTEMD_LINK_${PN} += "${SYNC_FMT}"
+SYSTEMD_LINK:${PN} += "${SYNC_FMT}"