summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor
diff options
context:
space:
mode:
authorManojkiran Eda <manojkiran.eda@gmail.com>2020-05-17 16:50:17 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-18 21:44:30 +0300
commitd2fb04ae7bcbc40c2466dd689bf76200b81c5a47 (patch)
tree4920f8a093f4b729162cbd630cdbdd2bcb3c05d8 /meta-ibm/recipes-phosphor
parenta250e50e814414c2f24e9028c661e5811f6dde5d (diff)
downloadopenbmc-d2fb04ae7bcbc40c2466dd689bf76200b81c5a47.tar.xz
Enable IBM Config Flag Recipe Support for Networkd
- This commit enables the ibm-config flag for phosphor-networkd service while compiling for IBM machines. - ibm-config compilation flag would enable the configurable Inventory-Interface Mapping JSON for setting the corresponding MAC Address that are obtanined from the Inventory on to the respective ethernet interface(s) during the first boot. (From meta-ibm rev: 4b0db6e07d3207e256f01f2f34d144aa93950224) Signed-off-by: Manojkiran Eda <manojkiran.eda@gmail.com> Fixed minor typo in commit message Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Change-Id: I31d284839969ea55f13165f5957c164b9b1f6ce8 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor')
-rw-r--r--meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend
index 178a921a0..76e440b0c 100644
--- a/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend
+++ b/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend
@@ -4,6 +4,8 @@ SRC_URI += " file://ncsi-netlink.service"
SYSTEMD_SERVICE_${PN} += " ncsi-netlink.service"
FILES_${PN} += "${datadir}/network/*.json"
+EXTRA_OECONF += "--enable-ibm-config"
+
install_network_configuration(){
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/ncsi-netlink.service ${D}${systemd_system_unitdir}