summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2019-06-28 19:19:11 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-09 14:35:07 +0300
commite4f02c2ead72f8d0acd994b75e6ff91aef55a568 (patch)
tree11f3f86fe1edd02b2d856dad11b5e31b2a10d50c /meta-ibm/recipes-phosphor
parentecca6634a6ed31955e8483fb1d648d3e571a6c8c (diff)
downloadopenbmc-e4f02c2ead72f8d0acd994b75e6ff91aef55a568.tar.xz
Enable TFTP updates via Redfish
TFTP is already enabled by default using the existing REST api's. Code was put in recently to also support TFTP via the Redfish UpdateServices.SimpleUpdate object. By default this is disabled within bmcweb. Enable it by default on all IBM systems to keep parity with the existing REST api's Tested: curl -k -H "X-Auth-Token: $TOKEN" -X GET https://${BMC_IP}/redfish/v1/UpdateService { "@odata.context": "/redfish/v1/$metadata#UpdateService.UpdateService", "@odata.id": "/redfish/v1/UpdateService", "@odata.type": "#UpdateService.v1_2_0.UpdateService", "Actions": { "#UpdateService.SimpleUpdate": { "TransferProtocol@Redfish.AllowableValues": [ "TFTP" ], "target": "/redfish/v1/UpdateService/Actions/UpdateService.SimpleUpdate" } (From meta-ibm rev: f93d1c8da15a0d73be54b80eb0f042733d1f314f) Change-Id: I2a9980b4bbb3bfd50550881e206154d1f69c0a24 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor')
-rw-r--r--meta-ibm/recipes-phosphor/bmcweb/bmcweb_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/bmcweb/bmcweb_%.bbappend b/meta-ibm/recipes-phosphor/bmcweb/bmcweb_%.bbappend
new file mode 100644
index 000000000..44f4f4695
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/bmcweb/bmcweb_%.bbappend
@@ -0,0 +1,3 @@
+EXTRA_OECMAKE_append = " \
+ -DBMCWEB_INSECURE_ENABLE_REDFISH_FW_TFTP_UPDATE=ON \
+"