summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2019-06-04 23:06:30 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-26 21:21:23 +0300
commit100f82716ecea62bdece469b0104962d14784a2b (patch)
treeb43b5dcab3fbbbd88729baa65b2337ad7a1ea554 /meta-ibm
parent7a589364c3bab1c942d77e7bdcc783d67f3fee85 (diff)
downloadopenbmc-100f82716ecea62bdece469b0104962d14784a2b.tar.xz
swift-ipmi: Hard coded sensor support
The Swift MRW has been updated and this commit utilizes some unused sensors for Swift starting at 0xFE and counting backwards (From meta-ibm rev: df212c93689bd73f0e760ed3cfffada6fa6b9ffa) Change-Id: Ica981d322f51fec94c0db94884938a60b637eb73 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb10
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/swift/acx22-ipmi-hwmon-sensors.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/acx22-ipmi-hwmon-sensors.yaml)68
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/witherspoon/ac922-ipmi-extra-hwmon-sensors.yaml84
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/witherspoon/acx22-ipmi-hwmon-sensors.yaml546
4 files changed, 591 insertions, 117 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
index efe9cd5d2..d0dbd60d8 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
@@ -6,10 +6,6 @@ LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd
inherit allarch
inherit mrw-xml
-EXTRA_SRC_URI = ""
-EXTRA_SRC_URI_witherspoon = " \
- file://ac922-ipmi-extra-hwmon-sensors.yaml \
- "
SRC_URI = " \
file://acx22-ipmi-fru-bmc.yaml \
file://acx22-ipmi-fru-not-sent-by-host.yaml \
@@ -17,7 +13,6 @@ SRC_URI = " \
file://acx22-ipmi-inventory-sensors.yaml \
file://acx22-ipmi-occ-sensors.yaml \
file://acx22-ipmi-sensors-mrw.yaml \
- ${EXTRA_SRC_URI} \
"
DEPENDS = " \
@@ -32,14 +27,9 @@ ACx22_IPMI_EXTRA_FRU_READ_YAMLS = " \
acx22-ipmi-fru-bmc.yaml \
acx22-ipmi-fru-not-sent-by-host.yaml \
"
-ACx22_IPMI_EXTRA_MACHINE_SENSOR_YAMLS = ""
-ACx22_IPMI_EXTRA_MACHINE_SENSOR_YAMLS_witherspoon = " \
- ac922-ipmi-extra-hwmon-sensors.yaml \
- "
ACx22_IPMI_EXTRA_SENSOR_YAMLS = " \
acx22-ipmi-hwmon-sensors.yaml \
acx22-ipmi-occ-sensors.yaml \
- ${ACx22_IPMI_EXTRA_MACHINE_SENSOR_YAMLS} \
"
do_install() {
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/acx22-ipmi-hwmon-sensors.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/swift/acx22-ipmi-hwmon-sensors.yaml
index 6d22a6132..38f38355a 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/acx22-ipmi-hwmon-sensors.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/swift/acx22-ipmi-hwmon-sensors.yaml
@@ -1,4 +1,4 @@
-221:
+232:
bExp: 0
entityID: 29
entityInstance: 1
@@ -19,7 +19,7 @@
sensorType: 4
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
-223:
+233:
bExp: 0
entityID: 29
entityInstance: 3
@@ -40,7 +40,7 @@
sensorType: 4
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
-227:
+234:
bExp: 0
entityID: 29
entityInstance: 5
@@ -61,7 +61,7 @@
sensorType: 4
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
-229:
+235:
bExp: 0
entityID: 29
entityInstance: 7
@@ -82,7 +82,7 @@
sensorType: 4
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
-231:
+236:
bExp: 0
entityID: 10
entityInstance: 1
@@ -103,7 +103,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-238:
+237:
bExp: 0
entityID: 10
entityInstance: 9
@@ -124,7 +124,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-239:
+238:
bExp: 0
entityID: 10
entityInstance: 10
@@ -145,7 +145,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-240:
+239:
bExp: 0
entityID: 10
entityInstance: 11
@@ -166,7 +166,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-241:
+240:
bExp: 0
entityID: 10
entityInstance: 12
@@ -187,7 +187,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-242:
+241:
bExp: 0
entityID: 10
entityInstance: 13
@@ -208,7 +208,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-243:
+242:
bExp: 0
entityID: 10
entityInstance: 14
@@ -229,7 +229,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-244:
+243:
bExp: 0
entityID: 10
entityInstance: 15
@@ -250,7 +250,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-245:
+244:
bExp: 0
entityID: 10
entityInstance: 16
@@ -271,7 +271,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-246:
+245:
bExp: 0
entityID: 10
entityInstance: 17
@@ -292,7 +292,7 @@
sensorType: 8
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
-247:
+246:
bExp: 0
entityID: 10
entityInstance: 19
@@ -313,7 +313,7 @@
sensorType: 2
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
-248:
+247:
bExp: 0
entityID: 10
entityInstance: 20
@@ -334,7 +334,7 @@
sensorType: 2
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
-249:
+248:
bExp: 0
entityID: 10
entityInstance: 21
@@ -355,7 +355,7 @@
sensorType: 2
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
-250:
+249:
bExp: 0
entityID: 10
entityInstance: 22
@@ -376,7 +376,7 @@
sensorType: 2
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
-251:
+250:
bExp: 0
entityID: 10
entityInstance: 23
@@ -397,7 +397,7 @@
sensorType: 3
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Amperes
-252:
+251:
bExp: 0
entityID: 10
entityInstance: 24
@@ -418,7 +418,7 @@
sensorType: 3
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.Amperes
-253:
+252:
bExp: 0
entityID: 35
entityInstance: 1
@@ -430,7 +430,28 @@
type: int64_t
multiplierM: 30
offsetB: 0
- path: /xyz/openbmc_project/sensors/temperature/pcie
+ path: /xyz/openbmc_project/sensors/temperature/pcie0_1
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 1
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+253:
+ bExp: 0
+ entityID: 35
+ entityInstance: 2
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 30
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/temperature/pcie2_3
rExp: -2
readingType: readingData
scale: -3
@@ -451,7 +472,7 @@
type: int64_t
multiplierM: 20
offsetB: 0
- path: /xyz/openbmc_project/sensors/temperature/ambient
+ path: /xyz/openbmc_project/sensors/temperature/ambient0
rExp: -2
readingType: readingData
scale: -3
@@ -460,3 +481,4 @@
sensorType: 1
serviceInterface: org.freedesktop.DBus.Properties
unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/witherspoon/ac922-ipmi-extra-hwmon-sensors.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/witherspoon/ac922-ipmi-extra-hwmon-sensors.yaml
deleted file mode 100644
index 538b4c867..000000000
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/witherspoon/ac922-ipmi-extra-hwmon-sensors.yaml
+++ /dev/null
@@ -1,84 +0,0 @@
-222:
- bExp: 0
- entityID: 29
- entityInstance: 2
- interfaces:
- xyz.openbmc_project.Sensor.Value:
- Value:
- Offsets:
- 255:
- type: int64_t
- multiplierM: 100
- offsetB: 0
- path: /xyz/openbmc_project/sensors/fan_tach/fan0_1
- rExp: 0
- readingType: readingData
- scale: 0
- sensorNamePattern: nameLeaf
- sensorReadingType: 1
- sensorType: 4
- serviceInterface: org.freedesktop.DBus.Properties
- unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
-226:
- bExp: 0
- entityID: 29
- entityInstance: 4
- interfaces:
- xyz.openbmc_project.Sensor.Value:
- Value:
- Offsets:
- 255:
- type: int64_t
- multiplierM: 100
- offsetB: 0
- path: /xyz/openbmc_project/sensors/fan_tach/fan1_1
- rExp: 0
- readingType: readingData
- scale: 0
- sensorNamePattern: nameLeaf
- sensorReadingType: 1
- sensorType: 4
- serviceInterface: org.freedesktop.DBus.Properties
- unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
-228:
- bExp: 0
- entityID: 29
- entityInstance: 6
- interfaces:
- xyz.openbmc_project.Sensor.Value:
- Value:
- Offsets:
- 255:
- type: int64_t
- multiplierM: 100
- offsetB: 0
- path: /xyz/openbmc_project/sensors/fan_tach/fan2_1
- rExp: 0
- readingType: readingData
- scale: 0
- sensorNamePattern: nameLeaf
- sensorReadingType: 1
- sensorType: 4
- serviceInterface: org.freedesktop.DBus.Properties
- unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
-230:
- bExp: 0
- entityID: 29
- entityInstance: 8
- interfaces:
- xyz.openbmc_project.Sensor.Value:
- Value:
- Offsets:
- 255:
- type: int64_t
- multiplierM: 100
- offsetB: 0
- path: /xyz/openbmc_project/sensors/fan_tach/fan3_1
- rExp: 0
- readingType: readingData
- scale: 0
- sensorNamePattern: nameLeaf
- sensorReadingType: 1
- sensorType: 4
- serviceInterface: org.freedesktop.DBus.Properties
- unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/witherspoon/acx22-ipmi-hwmon-sensors.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/witherspoon/acx22-ipmi-hwmon-sensors.yaml
new file mode 100644
index 000000000..803ed77ad
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/witherspoon/acx22-ipmi-hwmon-sensors.yaml
@@ -0,0 +1,546 @@
+221:
+ bExp: 0
+ entityID: 29
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan0_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+223:
+ bExp: 0
+ entityID: 29
+ entityInstance: 3
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan1_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+227:
+ bExp: 0
+ entityID: 29
+ entityInstance: 5
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan2_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+229:
+ bExp: 0
+ entityID: 29
+ entityInstance: 7
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan3_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+231:
+ bExp: 0
+ entityID: 10
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/fan_disk_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+238:
+ bExp: 0
+ entityID: 10
+ entityInstance: 9
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 1
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p0_io_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+239:
+ bExp: 0
+ entityID: 10
+ entityInstance: 10
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 1
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p1_io_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+240:
+ bExp: 0
+ entityID: 10
+ entityInstance: 11
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p0_mem_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+241:
+ bExp: 0
+ entityID: 10
+ entityInstance: 12
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p1_mem_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+242:
+ bExp: 0
+ entityID: 10
+ entityInstance: 13
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p0_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+243:
+ bExp: 0
+ entityID: 10
+ entityInstance: 14
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p1_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+244:
+ bExp: 0
+ entityID: 10
+ entityInstance: 15
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 10
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/ps0_input_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+245:
+ bExp: 0
+ entityID: 10
+ entityInstance: 16
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 10
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/ps1_input_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+246:
+ bExp: 0
+ entityID: 10
+ entityInstance: 17
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 20
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/total_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+247:
+ bExp: 0
+ entityID: 10
+ entityInstance: 19
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/voltage/ps0_input_voltage
+ rExp: 0
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 2
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+248:
+ bExp: 0
+ entityID: 10
+ entityInstance: 20
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/voltage/ps1_input_voltage
+ rExp: 0
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 2
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+249:
+ bExp: 0
+ entityID: 10
+ entityInstance: 21
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 10
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/voltage/ps0_output_voltage
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 2
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+250:
+ bExp: 0
+ entityID: 10
+ entityInstance: 22
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 10
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/voltage/ps1_output_voltage
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 2
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+251:
+ bExp: 0
+ entityID: 10
+ entityInstance: 23
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 1
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/current/ps0_output_current
+ rExp: 0
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 3
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Amperes
+252:
+ bExp: 0
+ entityID: 10
+ entityInstance: 24
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 1
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/current/ps1_output_current
+ rExp: 0
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 3
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Amperes
+253:
+ bExp: 0
+ entityID: 35
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 30
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/temperature/pcie
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 1
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+254:
+ bExp: 0
+ entityID: 64
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 20
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/temperature/ambient
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 1
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+222:
+ bExp: 0
+ entityID: 29
+ entityInstance: 2
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan0_1
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+226:
+ bExp: 0
+ entityID: 29
+ entityInstance: 4
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan1_1
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+228:
+ bExp: 0
+ entityID: 29
+ entityInstance: 6
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan2_1
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+230:
+ bExp: 0
+ entityID: 29
+ entityInstance: 8
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan3_1
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS