summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAbhishek Patel <Abhishek.Patel@ibm.com>2021-09-30 06:44:11 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-10-05 17:06:34 +0300
commit14d29c2fdfacccdba4622faf159c573466bd0b7c (patch)
treea2109188161503e9498b3b4c1899d47b7d0bac32 /meta-ibm
parent1167ada3a1af436b1c72a60bfdae004f01bc8674 (diff)
downloadopenbmc-14d29c2fdfacccdba4622faf159c573466bd0b7c.tar.xz
VUART1 socket name updated to Hypervisor
The Rainier and Tacoma using of both virtual UARTs provided by the AST2600. Expose them both to the network via obmc-console. where ttyVUART0 Exposer name is @obmc-console and ttyVUART1 Exposer name is @obmc-console.guests @obmc-console.guests initial exposed to access to phyp guests over that interface that why its name is guests, but now we are using that socket-it to run PHYP debug shell. So it is good to change the name of that exposer socket-id "guests" as "hypervisor". Signed-off-by: Abhishek Patel <Abhishek.Patel@ibm.com> Change-Id: I47dc71095795afbda8fb544fde4bcae78712093a
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf2
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf2
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf2
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf2
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend4
5 files changed, 6 insertions, 6 deletions
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf b/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf
index 7264e8278..7a4459123 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf
+++ b/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf
@@ -1 +1 @@
-socket-id = guests
+socket-id = hypervisor
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf b/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf
index 32e8bd467..8b3e8caee 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf
+++ b/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf
@@ -1,5 +1,5 @@
lpc-address = 0x2f8
sirq = 3
-socket-id = guests
+socket-id = hypervisor
logsize = 256k
logfile = /var/log/obmc-console1.log
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf b/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf
index 7264e8278..7a4459123 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf
+++ b/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf
@@ -1 +1 @@
-socket-id = guests
+socket-id = hypervisor
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf b/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf
index e98587f15..0bc52cc85 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf
+++ b/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf
@@ -1,3 +1,3 @@
lpc-address = 0x2f8
sirq = 3
-socket-id = guests
+socket-id = hypervisor
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
index 2ca97e165..436be4d74 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
@@ -30,7 +30,7 @@ install_concurrent_console_config() {
SRC_URI:append:p10bmc = " file://client.2201.conf"
SRC_URI:append:p10bmc = " file://server.ttyVUART1.conf"
-REGISTERED_SERVICES:${PN}:append:p10bmc = " obmc_console_guests:tcp:2201:"
+REGISTERED_SERVICES:${PN}:append:p10bmc = " obmc_console_hypervisor:tcp:2201:"
SYSTEMD_SERVICE:${PN}:append:p10bmc = " obmc-console-ssh@2200.service \
obmc-console-ssh@2201.service \
@@ -48,7 +48,7 @@ do_install:append:p10bmc() {
SRC_URI:append:witherspoon-tacoma = " file://client.2201.conf"
SRC_URI:append:witherspoon-tacoma = " file://server.ttyVUART1.conf"
-REGISTERED_SERVICES:${PN}:append:witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
+REGISTERED_SERVICES:${PN}:append:witherspoon-tacoma = " obmc_console_hypervisor:tcp:2201:"
SYSTEMD_SERVICE:${PN}:append:witherspoon-tacoma = " obmc-console-ssh@2200.service \
obmc-console-ssh@2201.service \