summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-17 23:51:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-26 04:27:12 +0300
commit3aa0aa841ef190e646f521b295c99f9889703798 (patch)
tree5c467167f3fe977088352bd15aa1c69d5fa6bc44 /meta-ibm
parent6a09593bbb3c7dc7ce21cdb60af79e5a1f5feb8e (diff)
downloadopenbmc-3aa0aa841ef190e646f521b295c99f9889703798.tar.xz
systemd: set zstd as default PACKAGECONFIG
Upstream supports zstd compression now as an alternative to zlib or xz. zstd is only slightly larger than xz but is significantly faster. This makes it a better candidate for the journal. Enable it in systemd instead of xz. Add an exemption for witherspoon to continue using xz instead. Having both zstd and xz support built into the image puts us over the flash limit and we currently need xz for phosphor-debug-collector. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I6fb55b96776aeeea1c544743b08bdbbc2853e7b7
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-core/systemd/systemd_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-ibm/recipes-core/systemd/systemd_%.bbappend b/meta-ibm/recipes-core/systemd/systemd_%.bbappend
index b61d9306d..354ea4055 100644
--- a/meta-ibm/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-ibm/recipes-core/systemd/systemd_%.bbappend
@@ -25,3 +25,9 @@ do_install:append:p10bmc() {
install -m 644 -D ${WORKDIR}/systemd-journald-override.conf ${D}${systemd_system_unitdir}/systemd-journald.service.d/systemd-journald-override.conf
install -m 644 -D ${WORKDIR}/journald-size-policy-16MB.conf ${D}${systemd_unitdir}/journald.conf.d/journald-size-policy.conf
}
+
+# Witherspoon doesn't have the space for the both zstd and xz compression
+# libraries and currently phosphor-debug-collector is using xz. Switch systemd
+# to use xz so only one of the two is added into the image.
+PACKAGECONFIG:remove:witherspoon = "zstd"
+PACKAGECONFIG:append:witherspoon = " xz"