summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-09-23 00:39:33 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-10-07 21:31:10 +0300
commit5170cc88253567d9a82a2fd7d424764b71b558fb (patch)
treeca44674e97b5ccb866daa3a35181f8e7baddcdc0 /meta-ibm
parent5523a1aba0c45959666b2ac0fac8cececf8e2a67 (diff)
downloadopenbmc-5170cc88253567d9a82a2fd7d424764b71b558fb.tar.xz
witherspoon-tacoma: disable host watchdog function
Hostboot utilizes inband IPMI on witherspoon-tacoma. They relied on OPAL firmware to continue pinging the watchdog and eventually disabling it. For the most part though, IBM utilizes PHYP on witherspoon-tacoma machines and they do not have the needed in-band IPMI support to do this. IBM needs either both firmware stacks (hostboot and PHYP) to use PLDM (i.e. p10bmc) or IPMI (witherspoon). Tacoma is an outlier so just disable the host watchdog function on Tacoma. Tested: - Verified a witherspoon-tacoma with PHYP booted successfully Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: Ibceb2ad6933973b97e122b83c89f6be7e7b8f868
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 38fbd717c..45678d981 100644
--- a/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,6 +1,9 @@
DEPENDS:append:ibm-ac-server = " acx22-yaml-config"
DEPENDS:append:mihawk = " acx22-yaml-config"
+# host watchdog does not work with witherspoon-tacoma host firmware
+RDEPENDS:${PN}:remove:witherspoon-tacoma = "virtual/obmc-watchdog"
+
EXTRA_OECONF:ibm-ac-server = " \
SENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-sensors.yaml \
INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
@@ -10,4 +13,4 @@ EXTRA_OECONF:mihawk = " \
SENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-sensors.yaml \
INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
FRU_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-fru-read.yaml \
- " \ No newline at end of file
+ "