summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:33:36 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-04 02:47:19 +0300
commit5b587cab386c4691eefa4885b9fd30794934c106 (patch)
tree9502dd5d3103b13ca91d7400056aa8d7d8800825 /meta-ibm
parentd9f7771a068f7e4b12fc4f77e49c56f26cf275d3 (diff)
downloadopenbmc-5b587cab386c4691eefa4885b9fd30794934c106.tar.xz
meta-phosphor: make discovery bbclass use override syntax
In the spirit of consistency with the new upstream override syntax, change phosphor-discovery-service.bbclass to use it and make tree-wide changes as appropriate. After the change checked on Witherspoon on QEMU: ``` root@witherspoon:/etc/avahi/services# ls obmc_console.service obmc_redfish.service obmc_rest.service ``` Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ib1fe3cce57a0130378af789abd83b457e0c3a318
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend4
-rw-r--r--meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
index 9360e2128..2ca97e165 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
@@ -30,7 +30,7 @@ install_concurrent_console_config() {
SRC_URI:append:p10bmc = " file://client.2201.conf"
SRC_URI:append:p10bmc = " file://server.ttyVUART1.conf"
-REGISTERED_SERVICES_${PN}:append:p10bmc = " obmc_console_guests:tcp:2201:"
+REGISTERED_SERVICES:${PN}:append:p10bmc = " obmc_console_guests:tcp:2201:"
SYSTEMD_SERVICE:${PN}:append:p10bmc = " obmc-console-ssh@2200.service \
obmc-console-ssh@2201.service \
@@ -48,7 +48,7 @@ do_install:append:p10bmc() {
SRC_URI:append:witherspoon-tacoma = " file://client.2201.conf"
SRC_URI:append:witherspoon-tacoma = " file://server.ttyVUART1.conf"
-REGISTERED_SERVICES_${PN}:append:witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
+REGISTERED_SERVICES:${PN}:append:witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
SYSTEMD_SERVICE:${PN}:append:witherspoon-tacoma = " obmc-console-ssh@2200.service \
obmc-console-ssh@2201.service \
diff --git a/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
index 659eafd74..8e06233b0 100644
--- a/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
+++ b/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -5,5 +5,5 @@ EXTRA_OEMESON:append = " \
inherit obmc-phosphor-discovery-service
-REGISTERED_SERVICES_${PN} += "obmc_redfish:tcp:443:"
-REGISTERED_SERVICES_${PN} += "obmc_rest:tcp:443:"
+REGISTERED_SERVICES:${PN} += "obmc_redfish:tcp:443:"
+REGISTERED_SERVICES:${PN} += "obmc_rest:tcp:443:"