summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-10-22 22:20:12 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-26 19:14:46 +0300
commit8c561eecb190655d51249c37286cc2c904dee7c0 (patch)
treea489df1bc284965502385f421d7d4f8464f1dfd9 /meta-ibm
parent9657ed3a430000aa40231e97d8bcaeb2a88fb247 (diff)
downloadopenbmc-8c561eecb190655d51249c37286cc2c904dee7c0.tar.xz
treewide: clean up recipe checks in OBMC_MACHINE_FEATURES
OBMC_MACHINE_FEATURES is a variable that probably shouldn't even exist as all it does is provide a level of indirection to the real MACHINE_FEATURES (in phosphor-base.inc, OBMC_ is added to the base). There are a few recipes that have developed checks against OBMC_MACHINE_FEATURES for enabling recipe-level features when they should be checking the standard MACHINE_FEATURES variable. Clean up this recipe-level indirection. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Id437b93aa6c1de9a27726eea9b7e2c30e71ab3bf
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend b/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
index 361417410..aa69617da 100644
--- a/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
+++ b/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
@@ -11,7 +11,7 @@ FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-logging/pels/ibm,rainier-4u_de
FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-logging/pels/ibm,everest_dev_callouts.json"
#Enable phal feature, if available.
-PACKAGECONFIG:append = " ${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
+PACKAGECONFIG:append = " ${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}"
PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata libekb pdbg"
do_install:append:p10bmc() {