summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-08-04 21:05:12 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-09-10 21:41:26 +0300
commitb06aaf02d0ab30acadf16b6126adef111b7585bb (patch)
tree18fd5d1151ee4d443f68905e96cdfea871eb5a56 /meta-ibm
parent1e03f2979f791f596fcc6e9ae7f3545e755b4cb6 (diff)
downloadopenbmc-b06aaf02d0ab30acadf16b6126adef111b7585bb.tar.xz
dbus-monitor: add dependency on snmp service
All IBM systems support the SNMP trap notification for error logs. This means phosphor-dbus-monitor needs to be careful to not start until the SNMP service is up and running. Without this dependency, situations can be hit, when lots of errors are present, where the phosphor-dbus-monitor calls into the SNMP shared library and hits an unhandled exception when trying to talk to the SNMP service. Tested: - Verified the unhandled exception is no longer seen and phosphor-dbus-monitor starts after the SNMP service. Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I8b4ca94c0cdd7721aa8847dc478f3827f040a654
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor/phosphor-dbus-monitor-snmp.conf3
-rw-r--r--meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend3
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor/phosphor-dbus-monitor-snmp.conf b/meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor/phosphor-dbus-monitor-snmp.conf
new file mode 100644
index 000000000..6b4f7f5d0
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor/phosphor-dbus-monitor-snmp.conf
@@ -0,0 +1,3 @@
+[Unit]
+Wants=mapper-wait@-xyz-openbmc_project-network-snmp.service
+After=mapper-wait@-xyz-openbmc_project-network-snmp.service
diff --git a/meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend b/meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend
index 6731a7abb..78d2d495f 100644
--- a/meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend
+++ b/meta-ibm/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend
@@ -1,2 +1,5 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
+
SYSTEMD_LINK:phosphor-msl-verify:append:ibm-ac-server = " ../phosphor-msl-verify.service:obmc-chassis-poweron@0.target.requires/phosphor-msl-verify.service"
SYSTEMD_LINK:phosphor-msl-verify:append:mihawk = " ../phosphor-msl-verify.service:obmc-chassis-poweron@0.target.requires/phosphor-msl-verify.service"
+SYSTEMD_OVERRIDE:${PN}:append = " phosphor-dbus-monitor-snmp.conf:phosphor-dbus-monitor.service.d/phosphor-dbus-monitor-snmp.conf"