summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2019-06-13 20:06:11 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-26 23:57:56 +0300
commitbc7b43faa96ea3f51715a337769db3d27ad6c895 (patch)
tree39db966d3b677bce19ea1bcd284cfc0a1658a30b /meta-ibm
parent2afe1b72ba4d667c3186213a0311cb05de901f6d (diff)
downloadopenbmc-bc7b43faa96ea3f51715a337769db3d27ad6c895.tar.xz
meta-ibm: phosphor-dbus-monitor non-native
Create the phosphor-dbus-monitor non-native recipes to allow the switch from native to non-native within the meta-ibm layer. Upon switching to the non-native recipe in meta-phosphor, these non-native recipes will then replace the native recipes in providing the policy configuration files(yaml). Tested: Built witherspoon phosphor-dbus-monitor resulting in no image change (From meta-ibm rev: 0ca32c6b6d0566a29756ecd05ffb748764296a27) Change-Id: Idf800c0d537b6051c3bc263908d9bbb2bc6ab2de Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend4
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy.bb17
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy.bb23
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy.bb17
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy.bb17
5 files changed, 78 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend
new file mode 100644
index 000000000..b1ced75a1
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend
@@ -0,0 +1,4 @@
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " witherspoon-fan-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " witherspoon-thermal-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " witherspoon-power-supply-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " witherspoon-events-policy"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy.bb
new file mode 100644
index 000000000..cca184aa4
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Event policy for Witherspoon"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-dbus-monitor
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI += "file://config.yaml"
+
+do_install() {
+ install -D ${WORKDIR}/config.yaml ${D}${config_dir}/config.yaml
+}
+
+FILES_${PN} += "${config_dir}/config.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy.bb
new file mode 100644
index 000000000..50c8c91e5
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Fan policy for Witherspoon"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-dbus-monitor
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI += "file://air-cooled.yaml"
+SRC_URI += "file://water-cooled.yaml"
+SRC_URI += "file://fan-errors.yaml"
+
+do_install() {
+ install -D ${WORKDIR}/air-cooled.yaml ${D}${config_dir}/air-cooled.yaml
+ install -D ${WORKDIR}/water-cooled.yaml ${D}${config_dir}/water-cooled.yaml
+ install -D ${WORKDIR}/fan-errors.yaml ${D}${config_dir}/fan-errors.yaml
+}
+
+FILES_${PN} += "${config_dir}/air-cooled.yaml"
+FILES_${PN} += "${config_dir}/water-cooled.yaml"
+FILES_${PN} += "${config_dir}/fan-errors.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy.bb
new file mode 100644
index 000000000..ef395b1c4
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Thermal policy for Witherspoon"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-dbus-monitor
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI += "file://thermal-policy.yaml"
+
+do_install() {
+ install -D ${WORKDIR}/thermal-policy.yaml ${D}${config_dir}/thermal-policy.yaml
+}
+
+FILES_${PN} += "${config_dir}/thermal-policy.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy.bb
new file mode 100644
index 000000000..774626691
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Power supply policy for Witherspoon"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-dbus-monitor
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI += "file://power-supply-policy.yaml"
+
+do_install() {
+ install -D ${WORKDIR}/power-supply-policy.yaml ${D}${config_dir}/power-supply-policy.yaml
+}
+
+FILES_${PN} += "${config_dir}/power-supply-policy.yaml"