summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2019-04-09 20:26:53 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-26 16:38:58 +0300
commitbc9ffb559b5a8b98cafae670444239b280c14b3c (patch)
treef29729bbfe034fd76c6c55fce194bddda3188837 /meta-ibm
parent50f884606b78c55005bb62f3a3421f019e48eebb (diff)
downloadopenbmc-bc9ffb559b5a8b98cafae670444239b280c14b3c.tar.xz
obmc-libobmc-intf: Add Swift gpio definitions
Add gpio definitions for the Swift machine under a swift subdir. Move the witherspoon gpio definitions under a witherspoon subdir. Tested: Built swift and witherspoon and checked that the file rootfs/etc/default/obmc/gpio/gpio_defs.json was correct for each machine. (From meta-ibm rev: dc61626406fc94962d31742832be83e574a28ee1) Change-Id: I812d1c0547744967d375984552f03f4702439de3 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/swift/gpio_defs.json63
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/witherspoon/gpio_defs.json (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend3
3 files changed, 65 insertions, 1 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/swift/gpio_defs.json b/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/swift/gpio_defs.json
new file mode 100644
index 000000000..83332db61
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/swift/gpio_defs.json
@@ -0,0 +1,63 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "SYS_PWROK_BUFF",
+ "power_up_outs": [
+ {"name": "SOFTWARE_PGOOD", "polarity": true},
+ {"name": "BMC_POWER_UP", "polarity": true}
+ ],
+ "reset_outs": [
+ {"name": "BMC_CP0_RESET_N", "polarity": false}
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "BMC_POWER_UP",
+ "pin": "A0",
+ "direction": "out"
+ },
+ {
+ "name": "SOFTWARE_PGOOD",
+ "pin": "R1",
+ "direction": "out"
+ },
+ {
+ "name": "SYS_PWROK_BUFF",
+ "pin": "A2",
+ "direction": "in"
+ },
+ {
+ "name": "CHECKSTOP",
+ "pin": "J2",
+ "direction": "falling"
+ },
+ {
+ "name": "BMC_CP0_RESET_N",
+ "pin": "A1",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_VS1_PERST_N",
+ "pin": "B7",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_CP0_PERST_ENABLE_R",
+ "pin": "A3",
+ "direction": "out"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "I3",
+ "direction": "both"
+ }
+ {
+ "name": "AIR_WATER_N",
+ "pin": "B5",
+ "direction": "in"
+ }
+ ]
+}
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/witherspoon/gpio_defs.json
index 5df8d0141..5df8d0141 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf/witherspoon/gpio_defs.json
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
index 72d991c7e..f24529606 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -1 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}/"
+FILESEXTRAPATHS_prepend_witherspoon-128 := "${THISDIR}/${PN}/witherspoon:"