summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorManojkiran Eda <manojkiran.eda@gmail.com>2021-06-08 13:17:53 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-08-10 15:33:07 +0300
commitbcc5f6b0f24e8ad0b03b8217e88a19ff3002c084 (patch)
tree9ee286a32d6026ec3603ce79af713874ddf665ae /meta-ibm
parent9b5ed4cc2fdcc2ad4ae320d7fe9206f9d1e153b9 (diff)
downloadopenbmc-bcc5f6b0f24e8ad0b03b8217e88a19ff3002c084.tar.xz
Override pldm response time out value
This commit would override response time out value for a request to 4.8 seconds for all the ibm machines. We have seen in our debugging that in rare cases host takes close to 5 seconds to respond to the pldm message.This value (4.8 seconds) is in sync with what phyp maintains for their messages(5 seconds). As we do lot of fileIO operations, and the number of PDR's tend to grow, picking 4.8 seconds seems to be less risky path & also larger timeout would reduce the number of retries from BMC incase if the host does not respond within 2-3 seconds. Signed-off-by: Manojkiran Eda <manojkiran.eda@gmail.com> Change-Id: Ic0eac42b66dbc2c6d69bff440fe590775f35e390
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/pldm/pldm_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/pldm/pldm_%.bbappend b/meta-ibm/recipes-phosphor/pldm/pldm_%.bbappend
index 32809764b..b57abd8f4 100644
--- a/meta-ibm/recipes-phosphor/pldm/pldm_%.bbappend
+++ b/meta-ibm/recipes-phosphor/pldm/pldm_%.bbappend
@@ -1,4 +1,8 @@
PACKAGECONFIG += "oem-ibm"
PACKAGECONFIG[oem-ibm] = "-Doem-ibm=enabled, -Doem-ibm=disabled, , squashfs-tools"
+EXTRA_OEMESON_append = " \
+ -Dresponse-time-out=4800 \
+"
+
SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'oem-ibm', 'pldm-create-phyp-nvram.service pldm-create-phyp-nvram-cksum.service', '', d)}"