summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2019-12-04 11:12:47 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-12-11 19:57:27 +0300
commite966fa3888f2ebddbe17fe6b117cc05384a22645 (patch)
treee59beacc2a6bc4caec581868a1de1791595dc43a /meta-ibm
parentd942f8dba8f76045215208f1b508af2f7598b888 (diff)
downloadopenbmc-e966fa3888f2ebddbe17fe6b117cc05384a22645.tar.xz
meta-witherspoon: Fix missing power-supply-monitor configs
The power-supply-monitor configs were installed by SYSTEMD_ENVIRONMENT_FILE_${PN}, which is defined in obmc-phosphor-systemd.bbclass. phosphor-power recipe does not inherit obmc-phosphor-systemd, results in the files installed by SYSTEMD_ENVIRONMENT_FILE_${PN} are not installed at all. Fix this issue by inherit obmc-phosphor-systemd in the bbappend. Tested: Verify the witherspoon build includes the power-supply-monitor configs. (From meta-ibm rev: d4374bf93e5927ccadb9de954384096ffb8590ec) Change-Id: Iaa3a04694c7b591d349a32529a0afef16239203d Signed-off-by: Lei YU <mine260309@gmail.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/phosphor-power_%.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/phosphor-power_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/power/phosphor-power_%.bbappend
index b90dc9b50..350c996d0 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/phosphor-power_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/phosphor-power_%.bbappend
@@ -1,5 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+inherit obmc-phosphor-systemd
+
SRC_URI += "file://psu.json"
EXTRA_OEMESON += "-Ducd90160-yaml=${STAGING_DIR_HOST}${datadir}/power-sequencer/ucd90160.yaml"
@@ -12,4 +14,4 @@ do_install_append(){
FILES_${PN} += "${datadir}/phosphor-power/psu.json"
PSU_MONITOR_ENV_FMT = "obmc/power-supply-monitor/power-supply-monitor-{0}.conf"
-SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'PSU_MONITOR_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_ibm-ac-server += "${@compose_list(d, 'PSU_MONITOR_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"