summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2021-08-19 18:17:45 +0300
committerMatthew Barth <msbarth@linux.ibm.com>2021-09-13 18:39:16 +0300
commitf90670136a3fe051b8b8e09215f790cac3c110ee (patch)
tree35c8190fd73dd3652a8923ca4d5d1c5d4d835282 /meta-ibm
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-f90670136a3fe051b8b8e09215f790cac3c110ee.tar.xz
meta-ibm:fans:presence: Use JSON config files installed from repo
The `witherspoon` and `p10bmc` machines' JSON config files should now use the JSON config files installed from the repository. Change-Id: Ie40264435ca5278a50f2aa3c688d882d72cb376b Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend35
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/everest/config.json90
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-1s4u/config.json86
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-2u/config.json134
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-4u/config.json128
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/witherspoon/config.json90
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend2
7 files changed, 0 insertions, 565 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
deleted file mode 100644
index 64dbc758b..000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ /dev/null
@@ -1,35 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI:witherspoon = "file://config.json"
-SRC_URI:p10bmc = "file://rainier-2u/config.json \
- file://rainier-4u/config.json \
- file://rainier-1s4u/config.json \
- file://everest/config.json \
- "
-
-do_install:witherspoon() {
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/
- install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
-}
-do_install:p10bmc() {
- # Install Rainier-2U/4U fan presence config files
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
- install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
- install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
- install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
-
- # Install Everest fan presence config file
- install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
- install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
-}
-
-FILES:${PN}:append:witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
-FILES:${PN}:remove:witherspoon = "${presence_datadir}/config.yaml"
-
-FILES:${PN}:remove:p10bmc = "${presence_datadir}/config.yaml"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/everest/config.json b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/everest/config.json
deleted file mode 100644
index 928eca25e..000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/everest/config.json
+++ /dev/null
@@ -1,90 +0,0 @@
-[
- {
- "name": "fan0",
- "path": "/system/chassis/motherboard/fan0",
- "methods": [
- {
- "type": "gpio",
- "key": 15,
- "physpath": "/sys/bus/i2c/devices/30-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan0_0",
- "fan0_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan1",
- "path": "/system/chassis/motherboard/fan1",
- "methods": [
- {
- "type": "gpio",
- "key": 14,
- "physpath": "/sys/bus/i2c/devices/30-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan1_0",
- "fan1_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan2",
- "path": "/system/chassis/motherboard/fan2",
- "methods": [
- {
- "type": "gpio",
- "key": 13,
- "physpath": "/sys/bus/i2c/devices/30-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan2_0",
- "fan2_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan3",
- "path": "/system/chassis/motherboard/fan3",
- "methods": [
- {
- "type": "gpio",
- "key": 12,
- "physpath": "/sys/bus/i2c/devices/30-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan3_0",
- "fan3_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- }
-]
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-1s4u/config.json b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-1s4u/config.json
deleted file mode 100644
index 65697e557..000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-1s4u/config.json
+++ /dev/null
@@ -1,86 +0,0 @@
-[
- {
- "name": "fan0",
- "path": "/system/chassis/motherboard/fan0",
- "methods": [
- {
- "type": "gpio",
- "key": 6,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan0_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan1",
- "path": "/system/chassis/motherboard/fan1",
- "methods": [
- {
- "type": "gpio",
- "key": 7,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan1_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan2",
- "path": "/system/chassis/motherboard/fan2",
- "methods": [
- {
- "type": "gpio",
- "key": 8,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan2_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan4",
- "path": "/system/chassis/motherboard/fan4",
- "methods": [
- {
- "type": "gpio",
- "key": 10,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan4_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- }
-]
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-2u/config.json b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-2u/config.json
deleted file mode 100644
index a5cc1bf66..000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-2u/config.json
+++ /dev/null
@@ -1,134 +0,0 @@
-[
- {
- "name": "fan0",
- "path": "/system/chassis/motherboard/fan0",
- "methods": [
- {
- "type": "gpio",
- "key": 6,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan0_0",
- "fan0_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan1",
- "path": "/system/chassis/motherboard/fan1",
- "methods": [
- {
- "type": "gpio",
- "key": 7,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan1_0",
- "fan1_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan2",
- "path": "/system/chassis/motherboard/fan2",
- "methods": [
- {
- "type": "gpio",
- "key": 8,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan2_0",
- "fan2_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan3",
- "path": "/system/chassis/motherboard/fan3",
- "methods": [
- {
- "type": "gpio",
- "key": 9,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan3_0",
- "fan3_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan4",
- "path": "/system/chassis/motherboard/fan4",
- "methods": [
- {
- "type": "gpio",
- "key": 10,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan4_0",
- "fan4_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan5",
- "path": "/system/chassis/motherboard/fan5",
- "methods": [
- {
- "type": "gpio",
- "key": 11,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan5_0",
- "fan5_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- }
-]
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-4u/config.json b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-4u/config.json
deleted file mode 100644
index 620a32907..000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/p10bmc/rainier-4u/config.json
+++ /dev/null
@@ -1,128 +0,0 @@
-[
- {
- "name": "fan0",
- "path": "/system/chassis/motherboard/fan0",
- "methods": [
- {
- "type": "gpio",
- "key": 6,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan0_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan1",
- "path": "/system/chassis/motherboard/fan1",
- "methods": [
- {
- "type": "gpio",
- "key": 7,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan1_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan2",
- "path": "/system/chassis/motherboard/fan2",
- "methods": [
- {
- "type": "gpio",
- "key": 8,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan2_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan3",
- "path": "/system/chassis/motherboard/fan3",
- "methods": [
- {
- "type": "gpio",
- "key": 9,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan3_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan4",
- "path": "/system/chassis/motherboard/fan4",
- "methods": [
- {
- "type": "gpio",
- "key": 10,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan4_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan5",
- "path": "/system/chassis/motherboard/fan5",
- "methods": [
- {
- "type": "gpio",
- "key": 11,
- "physpath": "/sys/bus/i2c/devices/7-0061",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan5_0"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- }
-]
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/witherspoon/config.json b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/witherspoon/config.json
deleted file mode 100644
index 52262fe35..000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/witherspoon/config.json
+++ /dev/null
@@ -1,90 +0,0 @@
-[
- {
- "name": "fan0",
- "path": "/system/chassis/motherboard/fan0",
- "methods": [
- {
- "type": "gpio",
- "key": 4,
- "physpath": "/sys/bus/i2c/devices/3-0060",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan0_0",
- "fan0_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan1",
- "path": "/system/chassis/motherboard/fan1",
- "methods": [
- {
- "type": "gpio",
- "key": 5,
- "physpath": "/sys/bus/i2c/devices/3-0060",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan1_0",
- "fan1_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan2",
- "path": "/system/chassis/motherboard/fan2",
- "methods": [
- {
- "type": "gpio",
- "key": 6,
- "physpath": "/sys/bus/i2c/devices/3-0060",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan2_0",
- "fan2_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- },
- {
- "name": "fan3",
- "path": "/system/chassis/motherboard/fan3",
- "methods": [
- {
- "type": "gpio",
- "key": 7,
- "physpath": "/sys/bus/i2c/devices/3-0060",
- "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
- },
- {
- "type": "tach",
- "sensors": [
- "fan3_0",
- "fan3_1"
- ]
- }
- ],
- "rpolicy": {
- "type": "anyof"
- }
- }
-]
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 469f76539..56a1ce966 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -59,12 +59,10 @@ SYSTEMD_LINK:${PN}-control:witherspoon += "${@compose_list(d, 'FMT_CONTROL_PWRON
# Enable the use of JSON on the fan applications that support it
PACKAGECONFIG:append:witherspoon = " json"
EXTRA_OECONF:append:witherspoon = " --disable-json-control"
-RDEPENDS:${PN}-presence-tach:append:witherspoon = " phosphor-fan-presence-config"
RDEPENDS:${PN}-monitor:append:witherspoon = " phosphor-fan-monitor-config"
PACKAGECONFIG:append:p10bmc = " json sensor-monitor"
FAN_PACKAGES:append:p10bmc = " sensor-monitor"
-RDEPENDS:${PN}-presence-tach:append:p10bmc = " phosphor-fan-presence-config"
RDEPENDS:${PN}-monitor:append:p10bmc = " phosphor-fan-monitor-config"
# Install fan control JSON config files