summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-05-24 16:35:53 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-05-27 16:39:10 +0300
commitf91639730c46b5c77cefe2ee6e689042e6a2fb31 (patch)
tree521894eda80ea492af99a3b742e0320cc0b6701d /meta-ibm
parentfb9869ff2816f52029c38b093d29e5a2c565d283 (diff)
downloadopenbmc-f91639730c46b5c77cefe2ee6e689042e6a2fb31.tar.xz
meta-ibm:host-watchdog: increase timeout to 10 min
The IBM host firmware team has requested an initial timeout of 10 minutes for the host watchdog. The goal is to bring this down once bringup is complete. When inband IPMI was used, there was a mechanism for the host to adjust this timeout so the BMC firmware would set the initial 30 second timeout and the host firmware would change it to 10 minutes once they started. With PLDM there is no way for the host to adjust this timeout so we need to start with the larger value. Tested: - Verified a p10bmc image had the new poweron file installed with 10 minute timeout. Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: If94766d5f2d62271c4adf366631f0b31a75ef8d0
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog/obmc/watchdog/poweron4
-rw-r--r--meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend4
2 files changed, 8 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog/obmc/watchdog/poweron b/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog/obmc/watchdog/poweron
new file mode 100644
index 000000000..d0b6e1024
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog/obmc/watchdog/poweron
@@ -0,0 +1,4 @@
+DEVPATH=/xyz/openbmc_project/watchdog/host0
+SERVICE=xyz.openbmc_project.Watchdog
+TARGET=obmc-host-timeout@0.target
+TIMEOUT_IN_MSEC=600000
diff --git a/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend b/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
new file mode 100644
index 000000000..0d9704fcc
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# utilize a 600s default timer config for p10bmc
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_p10bmc = " obmc/watchdog/poweron"