summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2021-06-21 15:26:05 +0300
committerJayanth Othayoth <ojayanth@in.ibm.com>2021-06-30 16:43:55 +0300
commitfa28a72fff271a78f805b41373f049a12b060fcb (patch)
tree4e35c58a7db88001f1293a93b473b251e778b38d /meta-ibm
parent1e40a42c7c1ce8608bfb406f3fedab05ef066f81 (diff)
downloadopenbmc-fa28a72fff271a78f805b41373f049a12b060fcb.tar.xz
meta-ibm: sbe error handling support
Phosphor logging PEL infrastructure provide supports to process SBE chip-op failures and creating PEL. PEL creation required to process SBE provided FFDC packets. This FFDC is initially created by SBE using FAPI based infrastructure for the hardware procedure execution failures. To extract this data to convert into PEL required format requires additional processing. This processing required PHAL(Power Hardware Abstraction layer) based back-end support. Added required packages support for PHAL feature enabled systems. Test: verified build. Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com> Change-Id: I5cf1a30514aa0a5bfdf2fe3a288dac9d5a0b5b47
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend b/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
index 2f0ace22b..ac43352c2 100644
--- a/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
+++ b/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
@@ -8,6 +8,10 @@ SRC_URI_append_p10bmc = " file://ibm,rainier-4u_dev_callouts.json"
FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-logging/pels/ibm,rainier-2u_dev_callouts.json"
FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-logging/pels/ibm,rainier-4u_dev_callouts.json"
+#Enable phal feature, if available.
+PACKAGECONFIG_append = " ${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
+PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata libekb pdbg"
+
do_install_append_p10bmc() {
install -d ${D}/${datadir}/phosphor-logging/pels
install -m 0644 ${WORKDIR}/ibm,rainier-2u_dev_callouts.json ${D}/${datadir}/phosphor-logging/pels/ibm,rainier-2u_dev_callouts.json