summaryrefslogtreecommitdiff
path: root/meta-inspur/meta-fp5280g2
diff options
context:
space:
mode:
authorJohn Wang <wangzqbj@inspur.com>2019-06-13 12:15:23 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-21 14:52:11 +0300
commit591aae151b2ee1770613702ef5a40c0f8f0f66a9 (patch)
treebafe15c8b6cc8b1de1bbb90558ca53bd78320fbf /meta-inspur/meta-fp5280g2
parent5ffc460d7c7fb99fb7ef0a04c469dbf528dc0f31 (diff)
downloadopenbmc-591aae151b2ee1770613702ef5a40c0f8f0f66a9.tar.xz
fp5280g2: Add fan presence yaml config
Fp5280g2 uses GPIOs to detect fan presences. Tested: Verified that the Present property in dbus corresponds correctly reflects wheather a fan is present or not. busctl get-property xyz.openbmc_project.Inventory.Manager /xyz/openbmc_project/inventory/system/chassis/motherboard/fan0 xyz.openbmc_project.Inventory.Item Present (From meta-inspur rev: 92dd17dc6efbf3eafc1a661e51ad5ae81ee8293d) Signed-off-by: John Wang <wangzqbj@inspur.com> Change-Id: I72960a336e003868df3fa1715bd9ca2c3383fdc1 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-inspur/meta-fp5280g2')
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend1
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml31
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-inspur/meta-fp5280g2/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
new file mode 100644
index 000000000..a5847a64f
--- /dev/null
+++ b/meta-inspur/meta-fp5280g2/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend_fp5280g2 := "${THISDIR}/${BPN}:"
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml b/meta-inspur/meta-fp5280g2/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml
new file mode 100644
index 000000000..31ac1ba47
--- /dev/null
+++ b/meta-inspur/meta-fp5280g2/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml
@@ -0,0 +1,31 @@
+- name: fan0
+ path: /system/chassis/motherboard/fan0
+ methods:
+ - type: gpio
+ key: 1
+ physpath: /sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a340.i2c-bus/i2c-8/8-0021
+ devpath: /dev/input/by-path/platform-gpio-keys-polled-event
+
+- name: fan1
+ path: /system/chassis/motherboard/fan1
+ methods:
+ - type: gpio
+ key: 2
+ physpath: /sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a340.i2c-bus/i2c-8/8-0021
+ devpath: /dev/input/by-path/platform-gpio-keys-polled-event
+
+- name: fan2
+ path: /system/chassis/motherboard/fan2
+ methods:
+ - type: gpio
+ key: 3
+ physpath: /sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a340.i2c-bus/i2c-8/8-0021
+ devpath: /dev/input/by-path/platform-gpio-keys-polled-event
+
+- name: fan3
+ path: /system/chassis/motherboard/fan3
+ methods:
+ - type: gpio
+ key: 4
+ physpath: /sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a340.i2c-bus/i2c-8/8-0021
+ devpath: /dev/input/by-path/platform-gpio-keys-polled-event