summaryrefslogtreecommitdiff
path: root/meta-inspur
diff options
context:
space:
mode:
authorGeorge Liu <liuxiwei@inspur.com>2021-04-13 13:56:03 +0300
committerGeorge Liu <liuxiwei@inspur.com>2021-04-15 15:31:21 +0300
commit587585739199cf94f34592bfc9dddd89c4a89b6d (patch)
tree389d8869bfa24b9082fba61247d52d851113f258 /meta-inspur
parentd043c0365499480ee8e15735f610e500cbf6e303 (diff)
downloadopenbmc-587585739199cf94f34592bfc9dddd89c4a89b6d.tar.xz
fp5280g2: leds: Remove the virtual LED configuration
- Previously, our purpose of using virtual LEDs was to use the default YAML and reconstruct the YAML configuration. - Currently, we use JSON instead of YAML, so we can remove the virtual LED configuration and use the default LEDs repo. Tested: Built fp5280g2 successfully and saw all the D-Bus object paths in the led-group-config.json file Signed-off-by: George Liu <liuxiwei@inspur.com> Change-Id: Ib99c5e3f87539180812a6ec011a86b3774516663
Diffstat (limited to 'meta-inspur')
-rw-r--r--meta-inspur/meta-fp5280g2/conf/machine/fp5280g2.conf1
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config-native.bb19
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config/led.yaml20
3 files changed, 0 insertions, 40 deletions
diff --git a/meta-inspur/meta-fp5280g2/conf/machine/fp5280g2.conf b/meta-inspur/meta-fp5280g2/conf/machine/fp5280g2.conf
index 8c66a4976..86663753e 100644
--- a/meta-inspur/meta-fp5280g2/conf/machine/fp5280g2.conf
+++ b/meta-inspur/meta-fp5280g2/conf/machine/fp5280g2.conf
@@ -7,7 +7,6 @@ OBMC_POWER_SUPPLY_INSTANCES = "0 1"
PREFERRED_PROVIDER_virtual/openpower-fru-vpd-layout = "fp5280g2-openpower-fru-vpd-layout-native"
PREFERRED_PROVIDER_virtual/openpower-fru-inventory = "fp5280g2-openpower-fru-inventory-native"
-PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native = "fp5280g2-led-manager-config-native"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config-native.bb b/meta-inspur/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config-native.bb
deleted file mode 100644
index 22aadad8e..000000000
--- a/meta-inspur/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config-native.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Phosphor LED Group Management for fp5280g2"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit native
-
-PROVIDES += "virtual/phosphor-led-manager-config-native"
-
-SRC_URI += "file://led.yaml"
-S = "${WORKDIR}"
-
-# Overwrite the example led layout yaml file prior
-# to building the phosphor-led-manager package
-do_install() {
- SRC=${S}
- DEST=${D}${datadir}/phosphor-led-manager
- install -D ${SRC}/led.yaml ${DEST}/led.yaml
-}
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config/led.yaml b/meta-inspur/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config/led.yaml
deleted file mode 100644
index 922d67bb7..000000000
--- a/meta-inspur/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config/led.yaml
+++ /dev/null
@@ -1,20 +0,0 @@
-bmc_booted:
- power:
- Action: 'Blink'
- DutyOn: 50
- Period: 1000
- Priority: 'On'
- init-ok:
- Action: 'On'
- DutyOn: 50
- Period: 0
- Priority: 'On'
-
-#fp5280g2 does not use "power" and "power_on". but the led.yaml needs it, otherwise the machine won't power on.
-power_on:
- power:
- Action: 'On'
- DutyOn: 50
- Period: 0
- Priority: 'On'
-