summaryrefslogtreecommitdiff
path: root/meta-inspur
diff options
context:
space:
mode:
authorGeorge Liu <liuxiwei@inspur.com>2021-05-27 14:42:33 +0300
committerGeorge Liu <liuxiwei@inspur.com>2021-06-02 11:17:07 +0300
commitbb9160afb99eaf8646a963195d2d9b7b3ecd8e81 (patch)
tree8924c25598305552be67d9943cf179d400759cd9 /meta-inspur
parent79eb2b53eef0c129985fba23d194e59e8fdb7441 (diff)
downloadopenbmc-bb9160afb99eaf8646a963195d2d9b7b3ecd8e81.tar.xz
fp5280g2: network: Enable First Boot Set MAC Feature
The intent behind this commit is to enable First Boot Set MAC Feature for Network Service and remove first-boot-set-mac. Because the `sync-mac` of the Network Service can set the MAC address at runtime(if the Inventory Objects are Added at Runtime). Tested: Built fp5280g2 successfully and saw eth0 & eth1 worked. Signed-off-by: George Liu <liuxiwei@inspur.com> Change-Id: I99967f84c64cbcac34adf95cf6a5084f8b1a185d
Diffstat (limited to 'meta-inspur')
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/network/first-boot-set-mac_%.bbappend1
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/network/phosphor-network/config.json4
-rw-r--r--meta-inspur/meta-fp5280g2/recipes-phosphor/network/phosphor-network_%.bbappend12
3 files changed, 16 insertions, 1 deletions
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/network/first-boot-set-mac_%.bbappend b/meta-inspur/meta-fp5280g2/recipes-phosphor/network/first-boot-set-mac_%.bbappend
deleted file mode 100644
index 934b328c7..000000000
--- a/meta-inspur/meta-fp5280g2/recipes-phosphor/network/first-boot-set-mac_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-SYSTEMD_SERVICE_${PN} += " first-boot-set-mac@eth0.service first-boot-set-mac@eth1.service"
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/network/phosphor-network/config.json b/meta-inspur/meta-fp5280g2/recipes-phosphor/network/phosphor-network/config.json
new file mode 100644
index 000000000..1df4eda7d
--- /dev/null
+++ b/meta-inspur/meta-fp5280g2/recipes-phosphor/network/phosphor-network/config.json
@@ -0,0 +1,4 @@
+{
+ "eth0":"eth0",
+ "eth1":"eth1"
+}
diff --git a/meta-inspur/meta-fp5280g2/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-inspur/meta-fp5280g2/recipes-phosphor/network/phosphor-network_%.bbappend
new file mode 100644
index 000000000..e8ac0e29c
--- /dev/null
+++ b/meta-inspur/meta-fp5280g2/recipes-phosphor/network/phosphor-network_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PACKAGECONFIG_append = " sync-mac"
+
+SRC_URI += "file://config.json"
+
+FILES_${PN} += "${datadir}/network"
+
+do_install_append() {
+ install -d ${D}${datadir}/network
+ install -m 0644 ${WORKDIR}/config.json ${D}${datadir}/network/
+}