summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2021-01-07 00:04:58 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-25 16:42:47 +0300
commit6510566f018b664b901835547891e08024616811 (patch)
treeda318cb1c7a59a4f172acb5052dbb2bd02bc0f8a /meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
parent5ff169f12d35c5e55ccc88d0e064d8cd39f87031 (diff)
downloadopenbmc-6510566f018b664b901835547891e08024616811.tar.xz
Move meta-intel to meta-intel-openbmc
meta-intel conflicts with the upstream yocto meta layer of the same name. This commit renames meta-intel to meta-intel-openbmc and updates all the relevant bblayers files with the new name. This is to pave the way for allowing the yocto meta-intel in the tree, which would allow the use of generic-x86 machine type, which would allow building and running tests natively. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: Ia19a7a4a10245c1c2f85f6da216997cb6a836daa
Diffstat (limited to 'meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
new file mode 100644
index 000000000..cdb88bbfe
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Intel DBus Interfaces"
+DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit python3native
+inherit phosphor-dbus-yaml
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
+
+SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
+SRCREV = "b5f2dd444c5d3808d005452417e4ae2ea28624ff"
+
+PACKAGECONFIG ??= "libintel_dbus"
+PACKAGECONFIG[libintel_dbus] = " \
+ --enable-libintel_dbus, \
+ --disable-libintel_dbus, \
+ systemd sdbusplus, \
+ libsystemd \
+ "
+
+PACKAGECONFIG_remove_class-native = "libintel_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
+
+BBCLASSEXTEND += "native nativesdk"