summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc
diff options
context:
space:
mode:
authorJae Hyun Yoo <jae.hyun.yoo@linux.intel.com>2021-08-06 20:55:59 +0300
committerVernon Mauery <vernon.mauery@linux.intel.com>2021-08-13 19:02:07 +0300
commit24e16a2cb140a5ab7c27d9f16f50ca6ce9531b9b (patch)
tree7ad9b1933fac80e4730c7f1ecba60a8bd4bcda48 /meta-intel-openbmc
parent28a6a30e9d546c70976549cffd7f970509220174 (diff)
downloadopenbmc-24e16a2cb140a5ab7c27d9f16f50ca6ce9531b9b.tar.xz
meta-intel-openbmc: prep for new override syntax
Ran `scripts/contrib/convert-overrides.py` from upstream Yocto and fixed up a few by hand that were missed. Tested: Built s2600wf. Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@linux.intel.com> Change-Id: I983385c8cdd4e2727c5c1a3d56952d6ac7fd89cc
Diffstat (limited to 'meta-intel-openbmc')
-rw-r--r--meta-intel-openbmc/conf/layer.conf2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend16
-rw-r--r--meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend10
-rwxr-xr-xmeta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb10
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb24
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb4
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb4
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend6
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend6
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend6
-rw-r--r--meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend2
-rw-r--r--meta-intel-openbmc/meta-s2600wf/conf/bblayers.conf.sample2
-rw-r--r--meta-intel-openbmc/meta-s2600wf/conf/layer.conf2
-rw-r--r--meta-intel-openbmc/meta-s2600wf/conf/local.conf.sample117
-rw-r--r--meta-intel-openbmc/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend2
20 files changed, 121 insertions, 102 deletions
diff --git a/meta-intel-openbmc/conf/layer.conf b/meta-intel-openbmc/conf/layer.conf
index e2133be24..3b53a7f1c 100644
--- a/meta-intel-openbmc/conf/layer.conf
+++ b/meta-intel-openbmc/conf/layer.conf
@@ -8,5 +8,5 @@ BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "intel"
BBFILE_PATTERN_intel = "^${LAYERDIR}/"
LAYERVERSION_intel = "1"
-LAYERSERIES_COMPAT_intel = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_intel = "gatesgarth hardknott honister"
LAYERDEPENDS_intel = "phosphor-layer"
diff --git a/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb b/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
index 1236cbfc7..7d30a7d83 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
@@ -11,6 +11,6 @@ SRCREV = "4a6e45c4c2f38bc64afe5faac05ea82b3adb8d93"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
EXTRA_OECMAKE = "-DYOCTO=1"
diff --git a/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend b/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
index 090b40e40..6f19a5e90 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-core/systemd/obmc-targets.bbappend
@@ -1,9 +1,9 @@
# Remove these files since they are provided by obmc-intel-targets
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-start@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-stop@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-reboot@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-startmin@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-poweron@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-poweroff@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-hard-poweroff@.target"
-SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-powerreset@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-start@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-stop@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-reboot@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-host-startmin@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-poweron@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-poweroff@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-hard-poweroff@.target"
+SYSTEMD_SERVICE:${PN}:remove:intel += " obmc-chassis-powerreset@.target"
diff --git a/meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend b/meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend
index c42693787..20cbaf8cd 100644
--- a/meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-extended/rsyslog/rsyslog_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://rsyslog.conf \
file://rsyslog.logrotate \
@@ -7,11 +7,11 @@ SRC_URI += "file://rsyslog.conf \
file://rsyslog-override.conf \
"
-FILES_${PN} += "${systemd_system_unitdir}/rsyslog.service.d/rsyslog-override.conf"
+FILES:${PN} += "${systemd_system_unitdir}/rsyslog.service.d/rsyslog-override.conf"
-PACKAGECONFIG_append = " imjournal"
+PACKAGECONFIG:append = " imjournal"
-do_install_append() {
+do_install:append() {
install -m 0644 ${WORKDIR}/rotate-event-logs.service ${D}${systemd_system_unitdir}
install -d ${D}${systemd_system_unitdir}/rsyslog.service.d
install -m 0644 ${WORKDIR}/rsyslog-override.conf \
@@ -21,4 +21,4 @@ do_install_append() {
rm ${D}${sysconfdir}/rsyslog.d/imjournal.conf
}
-SYSTEMD_SERVICE_${PN} += " rotate-event-logs.service"
+SYSTEMD_SERVICE:${PN} += " rotate-event-logs.service"
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
index 7327630f5..77d945c45 100755
--- a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -21,12 +21,12 @@ LIBRARY_NAMES = "libzinteloemcmds.so"
HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
-do_install_append(){
+do_install:append(){
install -d ${D}${includedir}/intel-ipmi-oem
install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/intel-ipmi-oem
}
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
index 8c0dfbf1c..098a91eb7 100644
--- a/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
@@ -16,29 +16,29 @@ PROVIDES += "virtual/obmc-fan-mgmt"
PROVIDES += "virtual/obmc-flash-mgmt"
PROVIDES += "virtual/obmc-system-mgmt"
-RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
-RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
-RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
-RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES:${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
-SUMMARY_${PN}-chassis = "Intel Chassis"
-RDEPENDS_${PN}-chassis = " \
+SUMMARY:${PN}-chassis = "Intel Chassis"
+RDEPENDS:${PN}-chassis = " \
x86-power-control \
obmc-host-failure-reboots \
"
-SUMMARY_${PN}-fans = "Intel Fans"
-RDEPENDS_${PN}-fans = " \
+SUMMARY:${PN}-fans = "Intel Fans"
+RDEPENDS:${PN}-fans = " \
phosphor-pid-control \
"
-SUMMARY_${PN}-flash = "Intel Flash"
-RDEPENDS_${PN}-flash = " \
+SUMMARY:${PN}-flash = "Intel Flash"
+RDEPENDS:${PN}-flash = " \
obmc-control-bmc \
"
-SUMMARY_${PN}-system = "Intel System"
-RDEPENDS_${PN}-system = " \
+SUMMARY:${PN}-system = "Intel System"
+RDEPENDS:${PN}-system = " \
bmcweb \
entity-manager \
intel-ipmi-oem \
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
index effd89b40..76d125ce8 100644
--- a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
@@ -12,7 +12,7 @@ SRCREV = "bcc7ce1f418c1a16a7868fee62499fa677242254"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.PFR.Manager.service"
+SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.PFR.Manager.service"
DEPENDS += " \
sdbusplus \
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
index 0d1d016fe..625a81921 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
@@ -7,5 +7,5 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit phosphor-mapper
inherit native
-PHOSPHOR_MAPPER_SERVICE_append = " com.intel"
-PHOSPHOR_MAPPER_INTERFACE_append = " com.intel"
+PHOSPHOR_MAPPER_SERVICE:append = " com.intel"
+PHOSPHOR_MAPPER_INTERFACE:append = " com.intel"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
index cdb88bbfe..ea2fe75bb 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -25,7 +25,7 @@ PACKAGECONFIG[libintel_dbus] = " \
libsystemd \
"
-PACKAGECONFIG_remove_class-native = "libintel_dbus"
-PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
+PACKAGECONFIG:remove:class-native = "libintel_dbus"
+PACKAGECONFIG:remove:class-nativesdk = "libintel_dbus"
BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
index ef991a58b..50f276aa6 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
@@ -1 +1 @@
-PHOSPHOR_MAPPER_CONFIGS_append_intel = " intel-dbus-interfaces-mapper-config-native"
+PHOSPHOR_MAPPER_CONFIGS:append:intel = " intel-dbus-interfaces-mapper-config-native"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 4521fe8f8..6d6912dca 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,5 +1,5 @@
-FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:intel := "${THISDIR}/${PN}:"
inherit obmc-phosphor-systemd
-SYSTEMD_SERVICE_${PN}_intel = "phosphor-pid-control.service"
-EXTRA_OECONF_intel = "--enable-configure-dbus=yes"
+SYSTEMD_SERVICE:${PN}:intel = "phosphor-pid-control.service"
+EXTRA_OECONF:intel = "--enable-configure-dbus=yes"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 876567f9a..652481d79 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,4 +1,4 @@
-do_install_append_intel(){
+do_install:append:intel(){
install -d ${D}${includedir}/phosphor-ipmi-host
install -m 0644 -D ${S}/sensorhandler.hpp ${D}${includedir}/phosphor-ipmi-host
install -m 0644 -D ${S}/selutility.hpp ${D}${includedir}/phosphor-ipmi-host
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
index e8cbbe928..29b98581f 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI_append = " file://ipmb-channels.json"
+SRC_URI:append = " file://ipmb-channels.json"
-do_install_append(){
+do_install:append(){
install -m 0644 -D ${WORKDIR}/ipmb-channels.json \
${D}/usr/share/ipmbbridge
}
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
index c7e2194ca..49b23e598 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
@@ -1 +1 @@
-PACKAGECONFIG_append_intel = " log-threshold"
+PACKAGECONFIG:append:intel = " log-threshold"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
index 590e9e629..a80a6d42d 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:intel := "${THISDIR}/${PN}:"
-SRC_URI_append_intel = " file://config.json"
+SRC_URI:append:intel = " file://config.json"
-do_compile_prepend_intel() {
+do_compile:prepend:intel() {
cp -r ${WORKDIR}/config.json ${S}/
}
diff --git a/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
index 5d47989b7..b27f9080b 100644
--- a/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
+++ b/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -1,2 +1,2 @@
# Use PLT_RST to detect warm resets
-EXTRA_OECMAKE_intel += "-DUSE_PLT_RST=ON"
+EXTRA_OECMAKE:intel += "-DUSE_PLT_RST=ON"
diff --git a/meta-intel-openbmc/meta-s2600wf/conf/bblayers.conf.sample b/meta-intel-openbmc/meta-s2600wf/conf/bblayers.conf.sample
index cbaf88b2e..1cfc1056f 100644
--- a/meta-intel-openbmc/meta-s2600wf/conf/bblayers.conf.sample
+++ b/meta-intel-openbmc/meta-s2600wf/conf/bblayers.conf.sample
@@ -1,6 +1,6 @@
# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
-LCONF_VERSION = "9"
+LCONF_VERSION = "8"
BBPATH = "${TOPDIR}"
BBFILES ?= ""
diff --git a/meta-intel-openbmc/meta-s2600wf/conf/layer.conf b/meta-intel-openbmc/meta-s2600wf/conf/layer.conf
index 82a9da0ae..936b1a9c0 100644
--- a/meta-intel-openbmc/meta-s2600wf/conf/layer.conf
+++ b/meta-intel-openbmc/meta-s2600wf/conf/layer.conf
@@ -8,4 +8,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "s2600wf"
BBFILE_PATTERN_s2600wf = ""
BBFILE_PRIORITY_s2600wf = "5"
-LAYERSERIES_COMPAT_s2600wf = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_s2600wf = "gatesgarth hardknott honister"
diff --git a/meta-intel-openbmc/meta-s2600wf/conf/local.conf.sample b/meta-intel-openbmc/meta-s2600wf/conf/local.conf.sample
index 89d11b682..c1a28e0b6 100644
--- a/meta-intel-openbmc/meta-s2600wf/conf/local.conf.sample
+++ b/meta-intel-openbmc/meta-s2600wf/conf/local.conf.sample
@@ -14,28 +14,7 @@
#
# Machine Selection
#
-# You need to select a specific machine to target the build with. There are a selection
-# of emulated machines available which can boot and run in the QEMU emulator:
-#
-#MACHINE ?= "qemuarm"
-#MACHINE ?= "qemuarm64"
-#MACHINE ?= "qemumips"
-#MACHINE ?= "qemuppc"
-#MACHINE ?= "qemux86"
-#MACHINE ?= "qemux86-64"
-#
-# There are also the following hardware board target machines included for
-# demonstration purposes:
-#
-#MACHINE ?= "beaglebone"
-#MACHINE ?= "genericx86"
-#MACHINE ?= "genericx86-64"
-#MACHINE ?= "mpc8315e-rdb"
-#MACHINE ?= "edgerouter"
-#
-# This sets the default machine to be qemux86 if no other machine is selected:
-
-MACHINE ?= "s2600wf"
+MACHINE ??= "s2600wf"
#
# Where to place downloads
@@ -49,6 +28,7 @@ MACHINE ?= "s2600wf"
# The default is a downloads directory under TOPDIR which is the build directory.
#
#DL_DIR ?= "${TOPDIR}/downloads"
+
#
# Where to place shared-state files
#
@@ -82,12 +62,12 @@ MACHINE ?= "s2600wf"
#
# The distribution setting controls which policy settings are used as defaults.
# The default value is fine for general Yocto project use, at least initially.
-# Ultimately when creating custom policy, people will likely end up subclassing
+# Ultimately when creating custom policy, people will likely end up subclassing
# these defaults.
#
DISTRO ?= "openbmc-phosphor"
# As an example of a subclass there is a "bleeding" edge policy configuration
-# where many versions are set to the absolute latest code from the upstream
+# where many versions are set to the absolute latest code from the upstream
# source control systems. This is just mentioned here as an example, its not
# useful to most new users.
# DISTRO ?= "poky-bleeding"
@@ -107,14 +87,13 @@ DISTRO ?= "openbmc-phosphor"
PACKAGE_CLASSES ?= "package_rpm"
#
-# SDK/ADT target architecture
+# SDK target architecture
#
-# This variable specifies the architecture to build SDK/ADT items for and means
+# This variable specifies the architecture to build SDK items for and means
# you can build the SDK packages for architectures other than the machine you are
# running the build on (i.e. building i686 packages on an x86_64 host).
-# Supported values are i686 and x86_64
+# Supported values are i686, x86_64, aarch64
#SDKMACHINE ?= "i686"
-SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
#
# Extra image configuration defaults
@@ -124,6 +103,8 @@ SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
# variable can contain the following options:
# "dbg-pkgs" - add -dbg packages for all installed packages
# (adds symbol information for debugging/profiling)
+# "src-pkgs" - add -src packages for all installed packages
+# (adds source code for debugging)
# "dev-pkgs" - add -dev packages for all installed packages
# (useful if you want to develop against libs in the image)
# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
@@ -131,14 +112,14 @@ SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
# "tools-debug" - add debugging tools (gdb, strace)
# "eclipse-debug" - add Eclipse remote debugging support
-# "tools-profile" - add profiling tools (oprofile, exmap, lttng, valgrind)
+# "tools-profile" - add profiling tools (oprofile, lttng, valgrind)
# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
# "debug-tweaks" - make an image suitable for development
# e.g. ssh root access has a blank password
# There are other application targets that can be used here too, see
# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
# We default to enabling the debugging tweaks.
-EXTRA_IMAGE_FEATURES = "debug-tweaks"
+EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
#
# Additional image features
@@ -147,20 +128,18 @@ EXTRA_IMAGE_FEATURES = "debug-tweaks"
# enable extra features. Some available options which can be included in this variable
# are:
# - 'buildstats' collect build statistics
-# - 'image-prelink' in order to prelink the filesystem image
-# - 'image-swab' to perform host system intrusion detection
-# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
-# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
-USER_CLASSES ?= "buildstats image-prelink"
+USER_CLASSES ?= "buildstats"
#
# Runtime testing of images
#
# The build system can test booting virtual machine images under qemu (an emulator)
-# after any root filesystems are created and run tests against those images. To
-# enable this uncomment this line. See classes/testimage(-auto).bbclass for
-# further details.
-#TEST_IMAGE = "1"
+# after any root filesystems are created and run tests against those images. It can also
+# run tests against any SDK that are built. To enable this uncomment these lines.
+# See classes/test{image,sdk}.bbclass for further details.
+#IMAGE_CLASSES += "testimage testsdk"
+#TESTIMAGE_AUTO_qemuall = "1"
+
#
# Interactive shell configuration
#
@@ -185,12 +164,12 @@ PATCHRESOLVE = "noop"
#
# Monitor the disk space during the build. If there is less that 1GB of space or less
# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
-# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# shutdown the build. If there is less than 100MB or 1K inodes, perform a hard abort
# of the build. The reason for this is that running completely out of space can corrupt
# files and damages the build in ways which may not be easily recoverable.
# It's necessary to monitor /tmp, if there is no space left the build will fail
# with very exotic errors.
-BB_DISKMON_DIRS = "\
+BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
@@ -203,7 +182,7 @@ BB_DISKMON_DIRS = "\
#
# Shared-state files from other locations
#
-# As mentioned above, shared state files are prebuilt cache data objects which can
+# As mentioned above, shared state files are prebuilt cache data objects which can be
# used to accelerate build time. This variable can be used to configure the system
# to search other mirror locations for these objects before it builds the data itself.
#
@@ -219,16 +198,56 @@ BB_DISKMON_DIRS = "\
#file://.* file:///some/local/dir/sstate/PATH"
#
+# Yocto Project SState Mirror
+#
+# The Yocto Project has prebuilt artefacts available for its releases, you can enable
+# use of these by uncommenting the following line. This will mean the build uses
+# the network to check for artefacts at the start of builds, which does slow it down
+# equally, it will also speed up the builds by not having to build things if they are
+# present in the cache. It assumes you can download something faster than you can build it
+# which will depend on your network.
+#
+#SSTATE_MIRRORS ?= "file://.* http://sstate.yoctoproject.org/2.5/PATH;downloadfilename=PATH"
+
+#
# Qemu configuration
#
-# By default qemu will build with a builtin VNC server where graphical output can be
-# seen. The two lines below enable the SDL backend too. This assumes there is a
-# libsdl library available on your build system.
-PACKAGECONFIG_append_pn-qemu-native = " sdl"
-PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
-#ASSUME_PROVIDED += "libsdl-native"
+# By default native qemu will build with a builtin VNC server where graphical output can be
+# seen. The line below enables the SDL UI frontend too.
+PACKAGECONFIG:append:pn-qemu-system-native = " sdl"
+# By default libsdl2-native will be built, if you want to use your host's libSDL instead of
+# the minimal libsdl built by libsdl2-native then uncomment the ASSUME_PROVIDED line below.
+#ASSUME_PROVIDED += "libsdl2-native"
+
+# You can also enable the Gtk UI frontend, which takes somewhat longer to build, but adds
+# a handy set of menus for controlling the emulator.
+#PACKAGECONFIG:append:pn-qemu-system-native = " gtk+"
+
+#
+# Hash Equivalence
+#
+# Enable support for automatically running a local hash equivalence server and
+# instruct bitbake to use a hash equivalence aware signature generator. Hash
+# equivalence improves reuse of sstate by detecting when a given sstate
+# artifact can be reused as equivalent, even if the current task hash doesn't
+# match the one that generated the artifact.
+#
+# A shared hash equivalent server can be set with "<HOSTNAME>:<PORT>" format
+#
+#BB_HASHSERVE = "auto"
+#BB_SIGNATURE_HANDLER = "OEEquivHash"
+
+#
+# Memory Resident Bitbake
+#
+# Bitbake's server component can stay in memory after the UI for the current command
+# has completed. This means subsequent commands can run faster since there is no need
+# for bitbake to reload cache files and so on. Number is in seconds, after which the
+# server will shut down.
+#
+#BB_SERVER_TIMEOUT = "60"
# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
# track the version of this file when it was generated. This can safely be ignored if
# this doesn't mean anything to you.
-CONF_VERSION = "1"
+CONF_VERSION = "2"
diff --git a/meta-intel-openbmc/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-intel-openbmc/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
index 410b21b4a..ea01f3742 100644
--- a/meta-intel-openbmc/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
+++ b/meta-intel-openbmc/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_s2600wf := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:s2600wf := "${THISDIR}/${PN}:"