summaryrefslogtreecommitdiff
path: root/meta-intel/meta-common
diff options
context:
space:
mode:
authorjmbills <42755197+jmbills@users.noreply.github.com>2019-10-25 19:18:16 +0300
committerGitHub <noreply@github.com>2019-10-25 19:18:16 +0300
commit0dbb60593ebb5a62190c0e6cff7f1770493303a2 (patch)
tree0df2ce67404dbca3ddc4ee063dbfd9ae455be682 /meta-intel/meta-common
parent34a3942845ac3264ce27c648ae5486d302c3e6d8 (diff)
parentcc9cea46d74d280de03c713c8b555153fd811f09 (diff)
downloadopenbmc-0dbb60593ebb5a62190c0e6cff7f1770493303a2.tar.xz
Merge branch 'intel' into intel2
Diffstat (limited to 'meta-intel/meta-common')
-rw-r--r--meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend16
-rwxr-xr-xmeta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb2
-rwxr-xr-xmeta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb2
-rw-r--r--meta-intel/meta-common/recipes-intel/libtinyxml2/libtinyxml2_%.bbappend3
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb2
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend2
-rw-r--r--meta-intel/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend6
-rw-r--r--meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend2
-rw-r--r--meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb2
-rw-r--r--meta-intel/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend2
-rw-r--r--meta-intel/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend6
11 files changed, 21 insertions, 24 deletions
diff --git a/meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend b/meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend
index 3fe1c3f38..090b40e40 100644
--- a/meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend
+++ b/meta-intel/meta-common/recipes-core/systemd/obmc-targets.bbappend
@@ -1,9 +1,9 @@
# Remove these files since they are provided by obmc-intel-targets
-SYSTEMD_SERVICE_${PN}_remove += " obmc-host-start@.target"
-SYSTEMD_SERVICE_${PN}_remove += " obmc-host-stop@.target"
-SYSTEMD_SERVICE_${PN}_remove += " obmc-host-reboot@.target"
-SYSTEMD_SERVICE_${PN}_remove += " obmc-host-startmin@.target"
-SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-poweron@.target"
-SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-poweroff@.target"
-SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-hard-poweroff@.target"
-SYSTEMD_SERVICE_${PN}_remove += " obmc-chassis-powerreset@.target"
+SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-start@.target"
+SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-stop@.target"
+SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-reboot@.target"
+SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-host-startmin@.target"
+SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-poweron@.target"
+SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-poweroff@.target"
+SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-hard-poweroff@.target"
+SYSTEMD_SERVICE_${PN}_remove_intel += " obmc-chassis-powerreset@.target"
diff --git a/meta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb b/meta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb
index b2d8a1f9b..b04e20fed 100755
--- a/meta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb
+++ b/meta-intel/meta-common/recipes-intel/chassis/x86-power-control_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/x86-power-control.git"
-SRCREV = "2c714052d62b1e8fdd19951bbd340ec41fd7ac5b"
+SRCREV = "f61ca6fdcc52beba485e014b5fad38a9e9a555ad"
inherit cmake pkgconfig pythonnative systemd
diff --git a/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
index e448d32e4..e0f9d9867 100755
--- a/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
+++ b/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
SRC_URI = "git://github.com/openbmc/intel-ipmi-oem"
-SRCREV = "63efafacfad59550c9a7edd926fcb162747ec2d8"
+SRCREV = "bf124d462bc5a6cb76637b3a2439e564d11a95e9"
S = "${WORKDIR}/git"
PV = "0.1+git${SRCPV}"
diff --git a/meta-intel/meta-common/recipes-intel/libtinyxml2/libtinyxml2_%.bbappend b/meta-intel/meta-common/recipes-intel/libtinyxml2/libtinyxml2_%.bbappend
deleted file mode 100644
index 60cfe5e9d..000000000
--- a/meta-intel/meta-common/recipes-intel/libtinyxml2/libtinyxml2_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-# update libtinyxml2 to version 6.0.0
-SRCREV = "8c8293ba8969a46947606a93ff0cb5a083aab47a"
-FILES_${PN}-dev += "${libdir}/cmake/tinyxml2/*"
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
index ce95082ce..0d1d016fe 100644
--- a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
@@ -2,7 +2,7 @@ SUMMARY="Add /com/intel namespace to phosphor-mapper"
DESCRIPTION="Add the /com/intel path namespace and \
com.intel interface prefix to the mapper watch list."
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit phosphor-mapper
inherit native
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend b/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
index 435531878..ef991a58b 100644
--- a/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
@@ -1 +1 @@
-PHOSPHOR_MAPPER_CONFIGS_append = " intel-dbus-interfaces-mapper-config-native"
+PHOSPHOR_MAPPER_CONFIGS_append_intel = " intel-dbus-interfaces-mapper-config-native"
diff --git a/meta-intel/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-intel/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 3e89746bf..4521fe8f8 100644
--- a/meta-intel/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-intel/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,5 +1,5 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
inherit obmc-phosphor-systemd
-SYSTEMD_SERVICE_${PN} = "phosphor-pid-control.service"
-EXTRA_OECONF = "--enable-configure-dbus=yes"
+SYSTEMD_SERVICE_${PN}_intel = "phosphor-pid-control.service"
+EXTRA_OECONF_intel = "--enable-configure-dbus=yes"
diff --git a/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index e5f63fbda..876567f9a 100644
--- a/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,4 +1,4 @@
-do_install_append(){
+do_install_append_intel(){
install -d ${D}${includedir}/phosphor-ipmi-host
install -m 0644 -D ${S}/sensorhandler.hpp ${D}${includedir}/phosphor-ipmi-host
install -m 0644 -D ${S}/selutility.hpp ${D}${includedir}/phosphor-ipmi-host
diff --git a/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
index 8ef3a5dfa..20df1185b 100644
--- a/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
+++ b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
@@ -5,7 +5,7 @@ inherit native
inherit obmc-phosphor-utils
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
PROVIDES += "virtual/phosphor-led-manager-config-native"
diff --git a/meta-intel/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend b/meta-intel/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
index 4be8ddbd5..3e769e174 100644
--- a/meta-intel/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
+++ b/meta-intel/meta-common/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
@@ -1,2 +1,2 @@
# Enable threshold monitoring
-EXTRA_OECMAKE += "-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=ON"
+EXTRA_OECMAKE_intel += "-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=ON"
diff --git a/meta-intel/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-intel/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
index ff1bfdb09..590e9e629 100644
--- a/meta-intel/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
+++ b/meta-intel/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
-SRC_URI_append = " file://config.json"
+SRC_URI_append_intel = " file://config.json"
-do_compile_prepend() {
+do_compile_prepend_intel() {
cp -r ${WORKDIR}/config.json ${S}/
}