summaryrefslogtreecommitdiff
path: root/meta-intel/meta-common
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-04-01 00:43:15 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-04 00:54:37 +0300
commit5181f43c2e3d881bb107a7f88a13d32286f0acd6 (patch)
tree4b349327ba6cd4160c89f1682f08960fd375b7b6 /meta-intel/meta-common
parente7fe5458d8d5405820de8a4f897848b64eef48e2 (diff)
downloadopenbmc-5181f43c2e3d881bb107a7f88a13d32286f0acd6.tar.xz
meta-intel: update DEPENDS for sdbusplus-native
sdbusplus has changed the package layout so that sdbusplus-native and sdbus++-native are now ${PYTHON_PN}-sdbus++-native. Update recipes that need to use sdbus++ (or its associated python modules) or remove the DEPENDS if it is no longer necessary. (From meta-intel rev: e7eeb8852d909cea02535cb8342c934fd61ed665) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I9b1b0299d3c65e8d9457dd559b71c0d96b29e59e Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-intel/meta-common')
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
index 76fb67dc3..cdb88bbfe 100644
--- a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -8,27 +8,24 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-inherit pythonnative
+inherit python3native
inherit phosphor-dbus-yaml
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbus++-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
SRCREV = "b5f2dd444c5d3808d005452417e4ae2ea28624ff"
-DEPENDS_remove_class-native = "sdbus++-native"
-DEPENDS_remove_class-nativesdk = "sdbus++-native"
-
PACKAGECONFIG ??= "libintel_dbus"
PACKAGECONFIG[libintel_dbus] = " \
--enable-libintel_dbus, \
--disable-libintel_dbus, \
systemd sdbusplus, \
- libsystemd sdbusplus \
+ libsystemd \
"
PACKAGECONFIG_remove_class-native = "libintel_dbus"
PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
-BBCLASSEXTEND += "native nativesdk" \ No newline at end of file
+BBCLASSEXTEND += "native nativesdk"