summaryrefslogtreecommitdiff
path: root/meta-inventec
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:17:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-02 16:19:25 +0300
commite83c22094b7e4970c96bcee273ab08d05bbc0a30 (patch)
tree80cb87a34afb07b7d375b534bb5df68468c2b5a6 /meta-inventec
parentd97cf9b9ef84cdad2f357164e36b76619e7dc379 (diff)
downloadopenbmc-e83c22094b7e4970c96bcee273ab08d05bbc0a30.tar.xz
meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override syntax, including the SYSTEMD_ variables. Change our systemd.bbclass to do the same for consistency and perform a tree-wide variable replacement. Spot checked by building bletchley and witherspoon and checking some of the SYSTEMD_LINK directives on installed packages under qemu. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
Diffstat (limited to 'meta-inventec')
-rw-r--r--meta-inventec/meta-lanyang/recipes-phosphor/chassis/avsbus-control.bb4
-rw-r--r--meta-inventec/meta-lanyang/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-inventec/meta-lanyang/recipes-phosphor/chassis/avsbus-control.bb b/meta-inventec/meta-lanyang/recipes-phosphor/chassis/avsbus-control.bb
index 956a62377..89b5b83e6 100644
--- a/meta-inventec/meta-lanyang/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-inventec/meta-lanyang/recipes-phosphor/chassis/avsbus-control.bb
@@ -16,9 +16,9 @@ FMT_OFF = "../${TMPL_OFF}:${TGTFMT_OFF}.wants/${INSTFMT_OFF}"
FMT_ON = "../${TMPL_ON}:${TGTFMT_ON}.requires/${INSTFMT_ON}"
SYSTEMD_SERVICE_${PN} += "${TMPL_OFF}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_OFF', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_OFF', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_SERVICE_${PN} += "${TMPL_ON}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ON', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_ON', 'OBMC_CHASSIS_INSTANCES')}"
SRC_URI += "file://lanyang_avsbus.sh"
RDEPENDS_${PN} += "i2c-tools"
diff --git a/meta-inventec/meta-lanyang/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-inventec/meta-lanyang/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
index eb8196ff3..deeb2f9eb 100644
--- a/meta-inventec/meta-lanyang/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
+++ b/meta-inventec/meta-lanyang/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -10,11 +10,11 @@ EEPROMS = "${@compose_list(d, 'EEPROMFMT', 'EEPROM_NAMES')}"
EEPROMS_ESCAPED = "${@compose_list(d, 'EEPROM_ESCAPEDFMT', 'EEPROM_NAMES')}"
ENVFMT = "obmc/eeproms/{0}"
-SYSTEMD_ENVIRONMENT_FILE_${PN}_append_lanyang := " ${@compose_list(d, 'ENVFMT', 'EEPROMS')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}_append_lanyang := " ${@compose_list(d, 'ENVFMT', 'EEPROMS')}"
TMPL = "obmc-read-eeprom@.service"
TGT = "multi-user.target"
INSTFMT = "obmc-read-eeprom@{0}.service"
FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
-SYSTEMD_LINK_${PN}_append_lanyang := " ${@compose_list(d, 'FMT', 'EEPROMS_ESCAPED')}"
+SYSTEMD_LINK:${PN}_append_lanyang := " ${@compose_list(d, 'FMT', 'EEPROMS_ESCAPED')}"