summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-10-22 23:54:16 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-10-22 23:54:16 +0300
commit9722c6ee87766a45a337c094d1293de81cdcb106 (patch)
tree08b57716ae3c02fef2bc870b634019e692fd70e6 /meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb
parent35e295e2a161fcf146ea031de53431b2888521fa (diff)
parent5b6cc97bf138293b6af12d5d3003bb66c700c48a (diff)
downloadopenbmc-9722c6ee87766a45a337c094d1293de81cdcb106.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into HEAD
Diffstat (limited to 'meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb
new file mode 100644
index 000000000..7c847f2ed
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices"
+DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+SRCREV = "${PV}"
+FILENAME = "Poleg_bootblock.bin"
+
+SRC_URI = "git://github.com/Nuvoton-Israel/npcm7xx-bootblock;protocol=git"
+SRC_URI[md5sum] = "cf8daa5f4636ed1ff952618e435af028"
+
+S = "${WORKDIR}/git"
+
+inherit deploy
+
+do_deploy () {
+ install -d ${DEPLOYDIR}
+ install -m 644 ${FILENAME} ${DEPLOYDIR}/
+}
+
+addtask deploy before do_build after do_compile