summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
authorBenjamin Fair <benjaminfair@google.com>2019-12-03 03:14:22 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-12-06 18:06:27 +0300
commit0290ed81fffb842b8c499dd7c6a503d0874f82ad (patch)
tree4ac0f8e7de25022d8f822ec5cfd7248a09280299 /meta-nuvoton
parent525792df16bbef378ce1f6595086e2a8b6c88072 (diff)
downloadopenbmc-0290ed81fffb842b8c499dd7c6a503d0874f82ad.tar.xz
meta-nuvoton: npcm7xx-bootblock: version the download name
Rename the bootblock image as it is being downloaded to contain the current version string. Currently, all versions of the bootblock are downloaded with the same file name. This breaks mirroring and reproducibility of builds since multiple versions can't be kept in a mirror at once. (From meta-nuvoton rev: 0978a0f77c6b213770f08804d3a9ea8f96946e7e) Change-Id: I06ee856dc2f6c5b3feda11205f34fa4443347345 Signed-off-by: Benjamin Fair <benjaminfair@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb
index 3f2178bff..22774cf65 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-FILENAME = "Poleg_bootblock.bin"
+FILENAME = "Poleg_bootblock_${PV}.bin"
S = "${WORKDIR}"
@@ -20,7 +20,7 @@ SRC_URI[bin.sha256sum] = "05f71da6ebb7798679fcffdcc928fbada8f941bd8e7a374ebc8261
inherit deploy
do_deploy () {
- install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/
+ install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/Poleg_bootblock.bin
}
addtask deploy before do_build after do_compile