summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
authorBenjamin Fair <benjaminfair@google.com>2019-10-31 04:40:41 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-12 19:51:10 +0300
commit6f6bd10f898f3a78c01a22508a5f3b9e444db32e (patch)
treebb29b55f60189d0d9cfdc87f12df664ca4c5c883 /meta-nuvoton
parentfbf258a361056e803832df080828c1dd75833840 (diff)
downloadopenbmc-6f6bd10f898f3a78c01a22508a5f3b9e444db32e.tar.xz
meta-nuvoton: npcm7xx-bootblock: update to 10.10.09
This version is open source, so fetch the LICENSE file from the source code along with the new binary. Eventually we can switch to building the binary form BitBake. (From meta-nuvoton rev: 63acac211ab4ef207057d596b18715d92b20a335) Change-Id: I5d95c41127e5a54520d6509402bb0ba8553aaa48 Signed-off-by: Benjamin Fair <benjaminfair@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb22
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb26
2 files changed, 26 insertions, 22 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb
deleted file mode 100644
index 7c847f2ed..000000000
--- a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices"
-DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices"
-HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
-LICENSE = "CLOSED"
-LIC_FILES_CHKSUM = ""
-
-SRCREV = "${PV}"
-FILENAME = "Poleg_bootblock.bin"
-
-SRC_URI = "git://github.com/Nuvoton-Israel/npcm7xx-bootblock;protocol=git"
-SRC_URI[md5sum] = "cf8daa5f4636ed1ff952618e435af028"
-
-S = "${WORKDIR}/git"
-
-inherit deploy
-
-do_deploy () {
- install -d ${DEPLOYDIR}
- install -m 644 ${FILENAME} ${DEPLOYDIR}/
-}
-
-addtask deploy before do_build after do_compile
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb
new file mode 100644
index 000000000..3f2178bff
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.09.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices"
+DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+FILENAME = "Poleg_bootblock.bin"
+
+S = "${WORKDIR}"
+
+SRCREV = "7bfef99f7a0354395519c4975f96d66cdda1fb67"
+SRC_URI = " \
+ https://raw.githubusercontent.com/Nuvoton-Israel/bootblock/${SRCREV}/LICENSE;name=lic \
+ https://github.com/Nuvoton-Israel/bootblock/releases/download/BootBlock_${PV}/Poleg_bootblock_basic.bin;downloadfilename=${FILENAME};name=bin \
+"
+
+SRC_URI[lic.md5sum] = "b234ee4d69f5fce4486a80fdaf4a4263"
+SRC_URI[bin.sha256sum] = "05f71da6ebb7798679fcffdcc928fbada8f941bd8e7a374ebc826131a0803e58"
+
+inherit deploy
+
+do_deploy () {
+ install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/
+}
+
+addtask deploy before do_build after do_compile