summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
authorkwliu <kwliu@nuvoton.com>2019-06-13 08:49:19 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-19 22:34:24 +0300
commit89ad9f366a1810d4c4d80e9073f4cd7426e764af (patch)
treeee621d2941d1dec02d18fac2adcf51cf386a9854 /meta-nuvoton
parentaedc3af90c1a21a72700e28639f53c110d17cf5c (diff)
downloadopenbmc-89ad9f366a1810d4c4d80e9073f4cd7426e764af.tar.xz
u-boot-nuvoton: move to 2019.01
Features and Drivers: - uart - flash - gmac/emc - sd/emmc - gpio - I2C master - pspi - USB host - USB mass storage - USB device controller - fuse - aes - rng - sha (From meta-nuvoton rev: 02b0bca47d62b2b5ffba0fc80cf9f10eeca7c6a4) Signed-off-by: kwliu <kwliu@nuvoton.com> Change-Id: Ibab2df0145256b75bc25173996aba68a2aa37998 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc6
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb4
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc b/meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc
index f5cb0fca3..d11327d82 100644
--- a/meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc
+++ b/meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc
@@ -3,11 +3,11 @@ SECTION = "bootloaders"
DEPENDS += "flex-native bison-native"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
-UBRANCH = "npcm7xx"
+UBRANCH = "npcm7xx-v2019.01"
SRC_URI = "git://github.com/Nuvoton-Israel/u-boot.git;branch=${UBRANCH}"
-SRCREV = "5d036755c2e13b5244f63ce052657e4ef3089bd5"
+SRCREV = "d8d75f72b9e324f47b0657dcaac9edf4433267ea"
S = "${WORKDIR}/git"
diff --git a/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb b/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
index 42bc7a306..7fc880ffd 100644
--- a/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
+++ b/meta-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
@@ -1,7 +1,7 @@
require u-boot-common-nuvoton.inc
SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
-DEPENDS = "mtd-utils"
+DEPENDS = "mtd-utils bison-native"
PROVIDES += "u-boot-fw-utils"
@@ -14,7 +14,7 @@ inherit uboot-config
do_compile () {
oe_runmake ${UBOOT_MACHINE}
- oe_runmake env
+ oe_runmake envtools
}
do_install () {