summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-12-14 22:31:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-30 23:37:44 +0300
commit0a8ea6354dd6b906f310316315fc49ace110a1ea (patch)
tree208ebd0de7c036c3b1d8b5cfe5037e27f4b60eaa /meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ
parent95eaf4978f6f92a848ba53accf02dcb52cee29b6 (diff)
downloadopenbmc-0a8ea6354dd6b906f310316315fc49ace110a1ea.tar.xz
Use variables for MRW XML filename and path
Create an mrw-xml bbclass that has variables for the MRW XML filename and path to it. Then, changes all users of the MRW XML to inherit that class and use those variables. The filename will default to ${MACHINE}.xml if it hasn't already been set to something else, such as in a .conf file. This is done so that the file can be something other than ${MACHINE}.xml. Change-Id: Ia7021e5a5d5e7946829e58688250aa64250cb00e Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
index aa831a58a..887b74163 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
@@ -5,6 +5,7 @@ inherit native
inherit obmc-phosphor-utils
inherit obmc-phosphor-license
inherit openpower-occ-control
+inherit mrw-xml
PROVIDES += "virtual/openpower-occ-control-config-native"
DEPENDS += "mrw-native mrw-perl-tools-native"
@@ -14,6 +15,6 @@ do_install_append() {
install -d ${YAML_DEST}/
${STAGING_BINDIR_NATIVE}/perl-native/perl \
${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \
- -i ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml \
+ -i ${mrw_datadir}/${MRW_XML} \
-o ${YAML_DEST}/occ_sensor.yaml
}