summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-08-22 22:11:18 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-08-30 22:46:11 +0300
commit8dac5fdbe854a5684664cd54f450094de0606a88 (patch)
tree548e3655a195e8baa3c453d112c6a06862a7d2ef /meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb
parentc99ab068784d737fa0cf547302270a0d30757509 (diff)
downloadopenbmc-8dac5fdbe854a5684664cd54f450094de0606a88.tar.xz
Add service to monitor the UCD90160 at runtime
This service starts the witherspoon-pseq-monitor application with the runtime-monitor argument (as opposed to the pgood-monitor argument). The service will start after PGOOD comes on. The application monitors for loss of PGOOD at runtime, in which case it will analyze the UCD90160 power sequencer chip for errors. It will also poll the chip for the errors that can only be detected that way. Resolves openbmc/openbmc#1724 Change-Id: Ieb456f56b6b4223cf9fe7a0635c5a3e725efcb29 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb
index 57ee0fe12..f9b0e2a02 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb
@@ -24,8 +24,11 @@ RDEPENDS_${PN} += " \
"
CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
+SEQ_MONITOR_SVC = "witherspoon-pseq-monitor.service"
+SEQ_MONITOR_FMT = "../${SEQ_MONITOR_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_MONITOR_SVC}"
+
SEQ_PGOOD_SVC = "witherspoon-pseq-monitor-pgood.service"
SEQ_PGOOD_FMT = "../${SEQ_PGOOD_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_PGOOD_SVC}"
-SYSTEMD_SERVICE_${PN} += "${SEQ_PGOOD_SVC}"
-SYSTEMD_LINK_${PN} += "${SEQ_PGOOD_FMT}"
+SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC}"
+SYSTEMD_LINK_${PN} += "${SEQ_MONITOR_FMT} ${SEQ_PGOOD_FMT}"