summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2500
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-12-16 23:21:26 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-12-17 00:07:50 +0300
commit4aeb24cf629a60980d4ad270fc1750754826613d (patch)
tree2b1448d35f422dfc4762616a1b9adbb8ff9d6ca0 /meta-openbmc-mods/meta-ast2500
parent506611d226c82d05215ec3d2dab50a43a531b691 (diff)
downloadopenbmc-4aeb24cf629a60980d4ad270fc1750754826613d.tar.xz
Update to internal 2019-12-16
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-ast2500')
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/0001-Blacklist-DIMM-Bus.patch26
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend5
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb2
3 files changed, 30 insertions, 3 deletions
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/0001-Blacklist-DIMM-Bus.patch b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/0001-Blacklist-DIMM-Bus.patch
new file mode 100644
index 000000000..e84e79884
--- /dev/null
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/0001-Blacklist-DIMM-Bus.patch
@@ -0,0 +1,26 @@
+From c64c2d05ebd9dcb9b161320087ce205a8a674a45 Mon Sep 17 00:00:00 2001
+From: James Feist <james.feist@linux.intel.com>
+Date: Wed, 11 Dec 2019 10:20:40 -0800
+Subject: [PATCH 1/1] Blacklist DIMM Bus
+
+The dimms error when being scanned, blacklist the bus.
+
+Change-Id: I797d144dc89b49ef7ac4f68b106a492014a4d086
+Signed-off-by: James Feist <james.feist@linux.intel.com>
+---
+ blacklist.json | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/blacklist.json b/blacklist.json
+index f112a7b..1ae6deb 100644
+--- a/blacklist.json
++++ b/blacklist.json
+@@ -1,3 +1,4 @@
+ {
+- "buses": []
++ "buses": [9]
+ }
++
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend
index 140bdb81a..35fb1cd85 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -1,5 +1,6 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-SRC_URI_append = " file://WC-Baseboard.json \
+SRC_URI_append = " file://0001-Blacklist-DIMM-Bus.patch \
+ file://WC-Baseboard.json \
file://WP-Baseboard.json \
file://TNP-baseboard.json \
file://FCXXPDBASSMBL_PDB.json \
@@ -11,7 +12,7 @@ SRC_URI_append = " file://WC-Baseboard.json \
RDEPENDS_${PN} += " default-fru"
-do_install_append(){
+do_install_append() {
install -d ${D}/usr/share/entity-manager/configurations
install -m 0444 ${WORKDIR}/*.json ${D}/usr/share/entity-manager/configurations
}
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb
index c91053536..637b836ba 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/workbook/wolfpass-config.bb
@@ -7,4 +7,4 @@ inherit config-in-skeleton
LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
SRCREV = "946064239016e38cd1cc346047b1d26960c06cdb"
-SKELETON_URI = "git://git@github.com/Intel-BMC/skeleton.git;protocol=ssh;branch=intel"
+SKELETON_URI = "git://github.com/Intel-BMC/skeleton.git;protocol=ssh;branch=intel"