summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2600
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 01:11:22 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 20:11:31 +0300
commitd071adf43ac87f21dde2f84287120960c723962c (patch)
tree05a1d365e0faa6ce8570b2d0c2d0f100dc8df1d4 /meta-openbmc-mods/meta-ast2600
parentf24c1e9afc47a421831278b57377951e71494d92 (diff)
downloadopenbmc-d071adf43ac87f21dde2f84287120960c723962c.tar.xz
Update to internal 0.66
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-ast2600')
-rw-r--r--meta-openbmc-mods/meta-ast2600/conf/layer.conf2
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0004-AST2600-Adjust-default-GPIO-settings.patch21
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0015-net-phy-realtek-Change-LED-configuration.patch40
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend1
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-phosphor/configuration/entity-manager/AC-Baseboard.json27
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console.conf2
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console@.service21
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console_%.bbappend10
8 files changed, 110 insertions, 14 deletions
diff --git a/meta-openbmc-mods/meta-ast2600/conf/layer.conf b/meta-openbmc-mods/meta-ast2600/conf/layer.conf
index 9c44d9b48..5faa28b7e 100644
--- a/meta-openbmc-mods/meta-ast2600/conf/layer.conf
+++ b/meta-openbmc-mods/meta-ast2600/conf/layer.conf
@@ -9,7 +9,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "ast2600"
BBFILE_PATTERN_ast2600 = ""
BBFILE_PRIORITY_ast2600 = "4"
-LAYERSERIES_COMPAT_ast2600 = "warrior zeus"
+LAYERSERIES_COMPAT_ast2600 = "zeus dunfell"
INHERIT += "extrausers"
#INHERIT += " cve-check"
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0004-AST2600-Adjust-default-GPIO-settings.patch b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0004-AST2600-Adjust-default-GPIO-settings.patch
index 1b2cc83a1..8659e4bfc 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0004-AST2600-Adjust-default-GPIO-settings.patch
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0004-AST2600-Adjust-default-GPIO-settings.patch
@@ -1,27 +1,30 @@
-From b6bce26bf19e74863e145e6e6e1f6e458077a31a Mon Sep 17 00:00:00 2001
+From 0381bd2a345dade03721a1244fa30eed4fade9fa Mon Sep 17 00:00:00 2001
From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
Date: Fri, 3 Jan 2020 15:14:09 -0800
Subject: [PATCH] AST2600: Adjust default GPIO settings
-- Disable GPIOC3 to prevent unexpected host failures.
+- Disabled GPIOC3 to prevent unexpected host failures.
- Fixed GPIOC5, GPIOG6, GPIOI0~7 and GPIOL6~7 directions and
default values.
- Disabled internal pull-down of GPIOB6.
+- Disabled HBLED.
Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
---
- board/aspeed/ast2600_intel/intel.c | 50 ++++++++++++++++++++++++++++++++++++++
- 1 file changed, 50 insertions(+)
+ board/aspeed/ast2600_intel/intel.c | 56 ++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 56 insertions(+)
diff --git a/board/aspeed/ast2600_intel/intel.c b/board/aspeed/ast2600_intel/intel.c
-index d1ac8651ac6c..b1a08db91bec 100644
+index d1ac8651ac6c..45f01a095340 100644
--- a/board/aspeed/ast2600_intel/intel.c
+++ b/board/aspeed/ast2600_intel/intel.c
-@@ -162,6 +162,54 @@ static void sgpio_init(void)
+@@ -162,6 +162,60 @@ static void sgpio_init(void)
SCU_BASE | SCU_414);
}
+#define SCU_410 0x410 /* Multi-function Pin Control #4 */
++#define SCU_69C 0x69C /* Multi-function Pin Control #27 */
++#define SCU_69C_HBLED_EN BIT(31)
+#define GPIO_000 0x000 /* GPIO A/B/C/D Value */
+#define GPIO_004 0x004 /* GPIO A/B/C/D Direction */
+#define GPIO_020 0x020 /* GPIO E/F/G/H Value */
@@ -31,6 +34,10 @@ index d1ac8651ac6c..b1a08db91bec 100644
+
+static void set_gpio_default_state(void)
+{
++ /* Default setting of Y23 pad in AST2600 A1 is HBLED so disable it. */
++ writel(readl(SCU_BASE | SCU_69C) & ~SCU_69C_HBLED_EN,
++ SCU_BASE | SCU_69C);
++
+#define SCU_410_RGMII3TXD1 BIT(19)
+#define GPIO_C3 BIT(19)
+
@@ -72,7 +79,7 @@ index d1ac8651ac6c..b1a08db91bec 100644
static void timer_handler(void *regs)
{
printf("+");
-@@ -175,6 +223,8 @@ int board_early_init_f(void)
+@@ -175,6 +229,8 @@ int board_early_init_f(void)
* I am not sure if it actually does anything... */
arch_interrupt_init_early();
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0015-net-phy-realtek-Change-LED-configuration.patch b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0015-net-phy-realtek-Change-LED-configuration.patch
new file mode 100644
index 000000000..d701d5a27
--- /dev/null
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/files/0015-net-phy-realtek-Change-LED-configuration.patch
@@ -0,0 +1,40 @@
+From 144b845cd597cb93e4a6143a194e5018f2176f23 Mon Sep 17 00:00:00 2001
+From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+Date: Fri, 5 Jun 2020 14:08:20 -0700
+Subject: [PATCH] net: phy: realtek: Change LED configuration
+
+This commit changes Realtek NIC port LED configuration like below:
+LED0 (Right Green): Link 10/100/1000
+LED1 (Left Orange): Link 10/100 + Blink on Tx/Rx
+LED2 (Left Green): Link 1000 + Blink on Tx/Rx
+
+Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+---
+ drivers/net/phy/realtek.c | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/drivers/net/phy/realtek.c b/drivers/net/phy/realtek.c
+index dd45e11b3ad9..167b34b2b2c9 100644
+--- a/drivers/net/phy/realtek.c
++++ b/drivers/net/phy/realtek.c
+@@ -169,10 +169,15 @@ static int rtl8211f_config(struct phy_device *phydev)
+ phy_write(phydev, MDIO_DEVAD_NONE,
+ MIIM_RTL8211F_PAGE_SELECT, 0x0);
+
+- /* Set green LED for Link, yellow LED for Active */
++ /*
++ * Set LED configuration
++ * LED0 (Right Grean): Link 10/100/1000
++ * LED1 (Left Orange): Link 10/100 + Active
++ * LED2 (Left Green): Link 1000 + Active
++ */
+ phy_write(phydev, MDIO_DEVAD_NONE,
+ MIIM_RTL8211F_PAGE_SELECT, 0xd04);
+- phy_write(phydev, MDIO_DEVAD_NONE, 0x10, 0x617f);
++ phy_write(phydev, MDIO_DEVAD_NONE, 0x10, 0x626b);
+ phy_write(phydev, MDIO_DEVAD_NONE,
+ MIIM_RTL8211F_PAGE_SELECT, 0x0);
+
+--
+2.7.4
+
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
index ae56f11eb..01f904a13 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2600/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
@@ -20,6 +20,7 @@ SRC_URI_append_intel-ast2600 = " \
file://0012-IPMI-command-handler-implementation-in-uboot.patch \
file://0013-Add-a-workaround-to-cover-UART-interrupt-bug-in-AST2.patch \
file://0014-Add-a-workaround-to-cover-eSPI-OOB-free-bug-in-AST26.patch \
+ file://0015-net-phy-realtek-Change-LED-configuration.patch \
"
PFR_SRC_URI = " \
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-phosphor/configuration/entity-manager/AC-Baseboard.json b/meta-openbmc-mods/meta-ast2600/recipes-phosphor/configuration/entity-manager/AC-Baseboard.json
index dd1c4d21a..6e1b3a22b 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-phosphor/configuration/entity-manager/AC-Baseboard.json
+++ b/meta-openbmc-mods/meta-ast2600/recipes-phosphor/configuration/entity-manager/AC-Baseboard.json
@@ -1151,7 +1151,7 @@
"OutLimitMax": 100.0,
"OutLimitMin": 30.0,
"Outputs": [
- "Pwm 12"
+ "Pwm 13"
],
"PCoefficient": 0.0,
"PositiveHysteresis": 0.0,
@@ -1177,7 +1177,7 @@
"OutLimitMax": 100.0,
"OutLimitMin": 30.0,
"Outputs": [
- "Pwm 13"
+ "Pwm 14"
],
"PCoefficient": 0.0,
"PositiveHysteresis": 0.0,
@@ -1203,7 +1203,7 @@
"OutLimitMax": 100.0,
"OutLimitMin": 30.0,
"Outputs": [
- "Pwm 14"
+ "Pwm 15"
],
"PCoefficient": 0.0,
"PositiveHysteresis": 0.0,
@@ -1229,7 +1229,7 @@
"OutLimitMax": 100.0,
"OutLimitMin": 30.0,
"Outputs": [
- "Pwm 15"
+ "Pwm 16"
],
"PCoefficient": 0.0,
"PositiveHysteresis": 0.0,
@@ -2031,6 +2031,25 @@
],
"Type": "XeonCPU",
"UseWA": 1
+ },
+ {
+ "Name": "ASD",
+ "BMC_RSMRST_B": {
+ "PinType": "PIN_NONE"
+ },
+ "BMC_SYSPWROK": {
+ "PinType": "PIN_NONE"
+ },
+ "BMC_PWR_DEBUG_N": {
+ "PinName": "FM_BMC_CPU_FBRK_OUT_R_N"
+ },
+ "BMC_DEBUG_EN_N": {
+ "PinType": "PIN_NONE"
+ },
+ "BMC_XDP_PRST_IN": {
+ "PinName": "DBP_PRESENT_IN_R2_N"
+ },
+ "Type": "ASD"
}
],
"Name": "AC Baseboard",
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console.conf b/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console.conf
index 748a26544..8491f5365 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console.conf
+++ b/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console.conf
@@ -1,3 +1,3 @@
baud = 115200
-local-tty = ttyS2
+local-tty = ttyS3
local-tty-baud = 115200
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console@.service b/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console@.service
new file mode 100644
index 000000000..7fb8f79d3
--- /dev/null
+++ b/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console/obmc-console@.service
@@ -0,0 +1,21 @@
+[Unit]
+Description=Phosphor Console Muxer listening on device /dev/%I
+BindsTo=dev-%i.device
+After=dev-%i.device
+
+[Service]
+ExecStartPre=/usr/bin/sol-option-check.sh
+ExecStartPre=/bin/sh -c 'echo -n "uart3" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart1'
+ExecStartPre=/bin/sh -c 'echo -n "uart1" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart3'
+ExecStartPre=/bin/sh -c 'echo -n "io1" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart4'
+ExecStartPre=/bin/sh -c 'echo -n "uart4" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/io1'
+ExecStart=/usr/bin/env obmc-console-server --config {sysconfdir}/obmc-console.conf %i
+ExecStopPost=/bin/sh -c 'echo -n "io1" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart1'
+ExecStopPost=/bin/sh -c 'echo -n "io3" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart3'
+ExecStopPost=/bin/sh -c 'echo -n "io4" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart4'
+ExecStopPost=/bin/sh -c 'echo -n "uart1" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/io1'
+SyslogIdentifier=obmc-console-server
+Restart=always
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console_%.bbappend b/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console_%.bbappend
index dee302fd7..7b6a47dac 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2600/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1,8 +1,16 @@
FILESEXTRAPATHS_prepend_intel-ast2600 := "${THISDIR}/${PN}:"
OBMC_CONSOLE_HOST_TTY = "ttyS2"
-SRC_URI += "file://sol-option-check.sh"
+SRC_URI += "file://sol-option-check.sh \
+ file://obmc-console@.service \
+ "
+inherit obmc-phosphor-systemd
+SYSTEMD_SERVICE_${PN} += " \
+ ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
+ "
do_install_append() {
+ rm -rf ${D}${base_libdir}/udev/rules.d/80-obmc-console-uart.rules
+ install -m 0644 ${WORKDIR}/${PN}@.service ${D}${systemd_system_unitdir}
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/sol-option-check.sh ${D}${bindir}
}