summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common-small
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 01:11:22 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 20:11:31 +0300
commitd071adf43ac87f21dde2f84287120960c723962c (patch)
tree05a1d365e0faa6ce8570b2d0c2d0f100dc8df1d4 /meta-openbmc-mods/meta-common-small
parentf24c1e9afc47a421831278b57377951e71494d92 (diff)
downloadopenbmc-d071adf43ac87f21dde2f84287120960c723962c.tar.xz
Update to internal 0.66
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common-small')
-rw-r--r--meta-openbmc-mods/meta-common-small/conf/layer.conf2
-rw-r--r--meta-openbmc-mods/meta-common-small/recipes-devtools/python/python-pycryptodomex.inc28
-rw-r--r--meta-openbmc-mods/meta-common-small/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb2
-rw-r--r--meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend1
4 files changed, 32 insertions, 1 deletions
diff --git a/meta-openbmc-mods/meta-common-small/conf/layer.conf b/meta-openbmc-mods/meta-common-small/conf/layer.conf
index 65569b5b2..a3c2fb4e7 100644
--- a/meta-openbmc-mods/meta-common-small/conf/layer.conf
+++ b/meta-openbmc-mods/meta-common-small/conf/layer.conf
@@ -8,4 +8,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "common-small"
BBFILE_PATTERN_common-small = "^${LAYERDIR}/"
BBFILE_PRIORITY_common-small = "10"
-LAYERSERIES_COMPAT_common-small = "warrior zeus"
+LAYERSERIES_COMPAT_common-small = "zeus dunfell"
diff --git a/meta-openbmc-mods/meta-common-small/recipes-devtools/python/python-pycryptodomex.inc b/meta-openbmc-mods/meta-common-small/recipes-devtools/python/python-pycryptodomex.inc
new file mode 100644
index 000000000..fa88defc1
--- /dev/null
+++ b/meta-openbmc-mods/meta-common-small/recipes-devtools/python/python-pycryptodomex.inc
@@ -0,0 +1,28 @@
+SUMMARY = "Cryptographic library for Python"
+DESCRIPTION = "PyCryptodome is a self-contained Python package of low-level\
+ cryptographic primitives."
+HOMEPAGE = "http://www.pycryptodome.org"
+LICENSE = "PD & BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=6dc0e2a13d2f25d6f123c434b761faba"
+
+SRC_URI[md5sum] = "46ba513d95b6e323734074d960a7d57b"
+SRC_URI[sha256sum] = "22d970cee5c096b9123415e183ae03702b2cd4d3ba3f0ced25c4e1aba3967167"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-math \
+"
+
+RDEPENDS_${PN}-tests += " \
+ ${PYTHON_PN}-unittest \
+"
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/Cryptodome/SelfTest/ \
+ ${PYTHON_SITEPACKAGES_DIR}/Cryptodome/SelfTest/__pycache__/ \
+"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openbmc-mods/meta-common-small/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb b/meta-openbmc-mods/meta-common-small/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb
new file mode 100644
index 000000000..be66430e1
--- /dev/null
+++ b/meta-openbmc-mods/meta-common-small/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb
@@ -0,0 +1,2 @@
+require python-pycryptodomex.inc
+inherit setuptools3
diff --git a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend
index d2855db1b..d9fed5138 100644
--- a/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend
+++ b/meta-openbmc-mods/meta-common-small/recipes-devtools/qemu/qemu-native_%.bbappend
@@ -6,3 +6,4 @@ QEMU_TARGETS = "arm"
S = "${WORKDIR}/git"
SRCREV = "8ab0db0624b454bd69a04ca0010f165cb7119100"
+PACKAGECONFIG[libudev] = ""