summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 01:23:08 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 02:21:22 +0300
commit67327ddc580cb9a85219a534844832a1682780d4 (patch)
tree307cedb87f4c0a329740c55ac364ed489d1d8fc2 /meta-openbmc-mods/meta-common/recipes-core/at-scale-debug
parentbb6a14e2f317abf60677c6ad8de9c33d5760bf36 (diff)
downloadopenbmc-67327ddc580cb9a85219a534844832a1682780d4.tar.xz
Update to internal 0.63
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/at-scale-debug')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb5
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/files/0001-Fix-build-error-in-kernel-v5.10.patch62
2 files changed, 2 insertions, 65 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb b/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb
index 10df9dd59..f35fee7ab 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb
+++ b/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/at-scale-debug_git.bb
@@ -4,7 +4,7 @@ SUMMARY = "At Scale Debug Service"
DESCRIPTION = "At Scale Debug Service exposes remote JTAG target debug capabilities"
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0d1c657b2ba1e8877940a8d1614ec560"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8929d33c051277ca2294fe0f5b062f38"
inherit cmake
@@ -13,8 +13,7 @@ DEPENDS = "sdbusplus openssl libpam libgpiod safec"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
SRC_URI = "git://github.com/Intel-BMC/asd;protocol=git"
-SRC_URI += "file://0001-Fix-build-error-in-kernel-v5.10.patch"
-SRCREV = "1.4.4"
+SRCREV = "1.4.6"
inherit useradd
diff --git a/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/files/0001-Fix-build-error-in-kernel-v5.10.patch b/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/files/0001-Fix-build-error-in-kernel-v5.10.patch
deleted file mode 100644
index 7ebedeee3..000000000
--- a/meta-openbmc-mods/meta-common/recipes-core/at-scale-debug/files/0001-Fix-build-error-in-kernel-v5.10.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 7ed9ba9738d8f27578ea2d00019f8245ee2a5556 Mon Sep 17 00:00:00 2001
-From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
-Date: Mon, 22 Feb 2021 15:32:13 -0800
-Subject: [PATCH] Fix build error in kernel v5.10
-
-Kernel headers should be added as last headers to prevent unexpected
-build breaks.
-
-Change-Id: Ie7d1a054baf2af88b9c46f928d0d84a64d8febd9
-Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
----
- i2c_handler.c | 5 +++--
- i2c_msg_builder.c | 5 +++--
- 2 files changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/i2c_handler.c b/i2c_handler.c
-index 21fb931..05470f4 100644
---- a/i2c_handler.c
-+++ b/i2c_handler.c
-@@ -29,8 +29,6 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
- #include <errno.h>
- #include <fcntl.h>
--#include <linux/i2c-dev.h>
--#include <linux/i2c.h>
- #include <stdint.h>
- #include <stdio.h>
- #include <stdlib.h>
-@@ -40,6 +38,9 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
- #include "logging.h"
-
-+#include <linux/i2c-dev.h>
-+#include <linux/i2c.h>
-+
- #define FILE_NAME "/dev/i2c"
- #define MAX_I2C_DEV_FILENAME 256
-
-diff --git a/i2c_msg_builder.c b/i2c_msg_builder.c
-index 6ae06a0..05dc340 100644
---- a/i2c_msg_builder.c
-+++ b/i2c_msg_builder.c
-@@ -27,13 +27,14 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
- #include "i2c_msg_builder.h"
-
--#include <linux/i2c-dev.h>
--#include <linux/i2c.h>
- #include <stdint.h>
- #include <stdlib.h>
-
- #include "logging.h"
-
-+#include <linux/i2c-dev.h>
-+#include <linux/i2c.h>
-+
- STATUS copy_i2c_to_asd(asd_i2c_msg* asd, struct i2c_msg* i2c);
- STATUS copy_asd_to_i2c(const asd_i2c_msg* asd, struct i2c_msg* i2c);
-
---
-2.17.1
-