summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.4.bb
diff options
context:
space:
mode:
authordheerajpdsk <p.dheeraj.srujan.kumar@intel.com>2022-05-06 12:32:30 +0300
committerGitHub <noreply@github.com>2022-05-06 12:32:30 +0300
commit0945170f93cc0c101bf01739f41136c2f05af570 (patch)
tree4899512512abc7e1529391ae48337ec8b40acced /meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.4.bb
parentca8d06bc610af08c2d3efc487aa9519989b743e6 (diff)
parent9cc183a531e1e309a99784f65b15c0fb1a18ddef (diff)
downloadopenbmc-0945170f93cc0c101bf01739f41136c2f05af570.tar.xz
Merge pull request #81 from Intel-BMC/update1-0.91-67
Update to internal 1-0.91-67
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.4.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.4.bb b/meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.4.bb
new file mode 100644
index 000000000..332dc0603
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.4.bb
@@ -0,0 +1,31 @@
+SUMMARY = "A stream-oriented XML parser library"
+DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
+HOMEPAGE = "http://expat.sourceforge.net/"
+SECTION = "libs"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
+
+VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
+
+SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
+ file://run-ptest \
+ "
+
+UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
+
+SRC_URI[sha256sum] = "14c58c2a0b5b8b31836514dfab41bd191836db7aa7b84ae5c47bc0327a20d64a"
+
+EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
+
+RDEPENDS:${PN}-ptest += "bash"
+
+inherit cmake lib_package ptest
+
+do_install_ptest:class-target() {
+ install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
+}
+
+BBCLASSEXTEND += "native nativesdk"
+
+CVE_PRODUCT = "expat libexpat"