summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.5.bb
diff options
context:
space:
mode:
authordheerajpdsk <p.dheeraj.srujan.kumar@intel.com>2022-06-16 23:47:53 +0300
committerGitHub <noreply@github.com>2022-06-16 23:47:53 +0300
commite0c224c79550bf49928bfb75f629233b1ef07c7a (patch)
treedfe08b91193d44f4984117dbd3eef9866e097582 /meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.5.bb
parent0945170f93cc0c101bf01739f41136c2f05af570 (diff)
parent1f4be67aa2cc61a3db46c577da5ccd88cc84fa16 (diff)
downloadopenbmc-e0c224c79550bf49928bfb75f629233b1ef07c7a.tar.xz
Merge pull request #82 from Intel-BMC/update1-0.91-151
Update to internal 1-0.91-151
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.5.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.5.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.5.bb b/meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.5.bb
new file mode 100644
index 000000000..b81c72515
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/expat/expat_2.4.5.bb
@@ -0,0 +1,31 @@
+SUMMARY = "A stream-oriented XML parser library"
+DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
+HOMEPAGE = "http://expat.sourceforge.net/"
+SECTION = "libs"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
+
+VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
+
+SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
+ file://run-ptest \
+ "
+
+UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
+
+SRC_URI[sha256sum] = "fbb430f964c7a2db2626452b6769e6a8d5d23593a453ccbc21701b74deabedff"
+
+EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
+
+RDEPENDS:${PN}-ptest += "bash"
+
+inherit cmake lib_package ptest
+
+do_install_ptest:class-target() {
+ install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
+}
+
+BBCLASSEXTEND += "native nativesdk"
+
+CVE_PRODUCT = "expat libexpat"