summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/systemd
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@intel.com>2022-01-07 00:50:19 +0300
committerJason M. Bills <jason.m.bills@intel.com>2022-01-14 22:27:54 +0300
commit1fc0d70f658da30091bcd49f9bf29aecd6b99ba7 (patch)
tree0b45c3beaa9874facc4ed1a2395a31e42be0135d /meta-openbmc-mods/meta-common/recipes-core/systemd
parent32777eec25d2c527a62e5ffab90a3dfef35855aa (diff)
downloadopenbmc-1fc0d70f658da30091bcd49f9bf29aecd6b99ba7.tar.xz
Update to internal 0.86
Signed-off-by: Jason M. Bills <jason.m.bills@intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/systemd')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/systemd/systemd/0001-Modfiy-system.conf-DefaultTimeoutStopSec.patch28
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/systemd/systemd/systemd-time-wait-sync.service36
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend17
3 files changed, 4 insertions, 77 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd/0001-Modfiy-system.conf-DefaultTimeoutStopSec.patch b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd/0001-Modfiy-system.conf-DefaultTimeoutStopSec.patch
deleted file mode 100644
index 5b9f17006..000000000
--- a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd/0001-Modfiy-system.conf-DefaultTimeoutStopSec.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From e02932693f92d6230b5520f431e127f7b6e2183e Mon Sep 17 00:00:00 2001
-From: James Feist <james.feist@linux.intel.com>
-Date: Tue, 6 Mar 2018 16:06:33 -0800
-Subject: [PATCH 1/1] Modfiy system.conf DefaultTimeoutStopSec
-
-Current time is 5 minutes, change it to 10 seconds.
-
-Signed-off-by: James Feist <james.feist@linux.intel.com>
----
- src/core/system.conf.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/core/system.conf.in b/src/core/system.conf.in
-index 8112125468..f7a35a56bb 100644
---- a/src/core/system.conf.in
-+++ b/src/core/system.conf.in
-@@ -39,7 +39,7 @@
- #DefaultStandardOutput=journal
- #DefaultStandardError=inherit
- #DefaultTimeoutStartSec=90s
--#DefaultTimeoutStopSec=90s
-+DefaultTimeoutStopSec=10s
- #DefaultTimeoutAbortSec=
- #DefaultRestartSec=100ms
- #DefaultStartLimitIntervalSec=10s
---
-2.17.1
-
diff --git a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd/systemd-time-wait-sync.service b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd/systemd-time-wait-sync.service
deleted file mode 100644
index f71aea39d..000000000
--- a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd/systemd-time-wait-sync.service
+++ /dev/null
@@ -1,36 +0,0 @@
-# SPDX-License-Identifier: LGPL-2.1+
-#
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-
-[Unit]
-Description=Wait Until Kernel Time Synchronized
-Documentation=man:systemd-time-wait-sync.service(8)
-
-# Note that this tool doesn't need CAP_SYS_TIME itself, but it's primary
-# usecase is to run in conjunction with a local NTP service such as
-# systemd-timesyncd.service, which is conditioned this way. There might be
-# niche usecases where running this service independently is desired, but let's
-# make this all "just work" for the general case, and leave it to local
-# modifications to make it work in the remaining cases.
-
-ConditionCapability=CAP_SYS_TIME
-ConditionVirtualization=!container
-
-DefaultDependencies=no
-Before=time-sync.target shutdown.target
-Wants=time-sync.target
-Conflicts=shutdown.target
-
-[Service]
-Type=oneshot
-ExecStart=/lib/systemd/systemd-time-wait-sync
-TimeoutStartSec=10
-RemainAfterExit=yes
-
-[Install]
-WantedBy=sysinit.target
diff --git a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend
index 50f82d21e..2eb5330d8 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend
@@ -1,20 +1,11 @@
# add some configuration overrides for systemd defaults
-LICENSE = "GPL-2.0"
-
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://0001-Modfiy-system.conf-DefaultTimeoutStopSec.patch \
- file://systemd-time-wait-sync.service \
- file://0002-Add-event-log-for-system-time-synchronization.patch \
+SRC_URI += "file://0002-Add-event-log-for-system-time-synchronization.patch \
"
-USERADD_PACKAGES:remove = "${PN}-journal-gateway ${PN}-journal-upload ${PN}-journal-remote"
-
-do_install:append(){
- rm -rf ${D}/lib/udev/rules.d/80-drivers.rules
- cp -f ${WORKDIR}/systemd-time-wait-sync.service ${D}/lib/systemd/system/
-}
-
-PACKAGECONFIG:remove = " kmod"
+# We don't support loadable modules in kernel config
+PACKAGECONFIG:remove = "kmod"
+# Add systemd-logind service to get shutdown inhibition support
PACKAGECONFIG:append = " logind"