summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-devtools/rsync/files/determism.patch
diff options
context:
space:
mode:
authordheerajpdsk <p.dheeraj.srujan.kumar@intel.com>2022-12-13 12:17:13 +0300
committerGitHub <noreply@github.com>2022-12-13 12:17:13 +0300
commit9ad1806592d6c8e3111b9c26db1882f2af49d64c (patch)
treede9cd6bf9a4312ca38c65f68faa41638693237a0 /meta-openbmc-mods/meta-common/recipes-devtools/rsync/files/determism.patch
parente9e8ce6060c3c89cff2ca181cf95e3dec1a6c78d (diff)
parent2856c9ab56260bdd398de617bf610e4f7334cafd (diff)
downloadopenbmc-9ad1806592d6c8e3111b9c26db1882f2af49d64c.tar.xz
Merge pull request #126 from Intel-BMC/update1-0.92-41
Update to internal 1-0.92-41
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-devtools/rsync/files/determism.patch')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-devtools/rsync/files/determism.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-devtools/rsync/files/determism.patch b/meta-openbmc-mods/meta-common/recipes-devtools/rsync/files/determism.patch
new file mode 100644
index 000000000..e3494fdde
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-devtools/rsync/files/determism.patch
@@ -0,0 +1,34 @@
+The Makefile calls awk on a "*.c" glob. The results of this glob are sorted
+but the order depends on the locale settings, particularly whether
+"util.c" and "util2.c" sort before or after each other. In en_US.UTF-8
+they sort one way, in C, they sort the other. The sorting order changes
+the output binaries. The behaviour also changes dependning on whether
+SHELL (/bin/sh) is dash or bash.
+
+Specify a C locale setting to be deterministic.
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Submitted: https://github.com/WayneD/rsync/pull/155
+
+Upstream-Status: Backport [ish, see below]
+
+After discussion upstream renamed util.c to util1.c which avoids the problem
+in a different way. This patch can be dropped when we upgrade to include:
+https://github.com/WayneD/rsync/commit/d3085f7add38a5cf833a0b31cb0637ff46c80f8d
+
+Index: rsync-3.2.3/Makefile.in
+===================================================================
+--- rsync-3.2.3.orig/Makefile.in
++++ rsync-3.2.3/Makefile.in
+@@ -26,6 +26,11 @@ MKDIR_P=@MKDIR_P@
+ VPATH=$(srcdir)
+ SHELL=/bin/sh
+
++# We use globbing in commands, need to be deterministic
++unexport LC_ALL
++LC_COLLATE=C
++export LC_COLLATE
++
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+