summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/nvmemi-daemon.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:13:22 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 23:02:05 +0300
commitab16ab3d0de4dc9d130ae3db366c38888f1ada5a (patch)
treed7b76b8111aedb06ee17ced2c9cbdebaeaaf6311 /meta-openbmc-mods/meta-common/recipes-phosphor/pmci/nvmemi-daemon.bb
parent36caa12533da01d4319c5ffe7613711a0ec7dea7 (diff)
downloadopenbmc-ab16ab3d0de4dc9d130ae3db366c38888f1ada5a.tar.xz
Update to internal 0.45
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/pmci/nvmemi-daemon.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/pmci/nvmemi-daemon.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/nvmemi-daemon.bb b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/nvmemi-daemon.bb
new file mode 100644
index 000000000..510535363
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/nvmemi-daemon.bb
@@ -0,0 +1,17 @@
+SUMMARY = "NVMe MI Daemon"
+DESCRIPTION = "Implementation of NVMe MI daemon"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "git://github.com/Intel-BMC/nvme-mi.git;protocol=ssh;nobranch=1"
+SRCREV = "23fad1d6ffd8ccd16b1369b96734a9701fc2802a"
+S = "${WORKDIR}/git"
+PV = "1.0+git${SRCPV}"
+
+inherit meson systemd
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.nvme-mi.service"
+DEPENDS = "boost sdbusplus systemd phosphor-logging mctpwplus googletest"
+
+EXTRA_OEMESON = "-Dyocto_dep='enabled' -Dtests='enabled'"