summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-support/boost
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-08-04 01:40:26 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-08-04 23:23:32 +0300
commit40108db4434d8c2e0a1ad2d1dd3f5ae34b17352c (patch)
tree14edb2241a48b600f217aa8ebc03a59ed62ca268 /meta-openbmc-mods/meta-common/recipes-support/boost
parentd071adf43ac87f21dde2f84287120960c723962c (diff)
downloadopenbmc-40108db4434d8c2e0a1ad2d1dd3f5ae34b17352c.tar.xz
Update to internal 0.72
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-support/boost')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-support/boost/boost/0001-Fix-Issue-62.patch28
-rw-r--r--meta-openbmc-mods/meta-common/recipes-support/boost/boost_%.bbappend3
2 files changed, 0 insertions, 31 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-support/boost/boost/0001-Fix-Issue-62.patch b/meta-openbmc-mods/meta-common/recipes-support/boost/boost/0001-Fix-Issue-62.patch
deleted file mode 100644
index 80dfc2725..000000000
--- a/meta-openbmc-mods/meta-common/recipes-support/boost/boost/0001-Fix-Issue-62.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 318439af2e77731ae2c3df5e198c1d3e8392d556 Mon Sep 17 00:00:00 2001
-From: Simon Ebner <Simon.Ebner@advertima.com>
-Date: Fri, 22 Mar 2019 15:27:35 +0100
-Subject: [PATCH 1/2] Fix Issue 62
-
-Fixes a leaking pipe. See https://github.com/boostorg/process/issues/62
----
- boost/process/detail/posix/executor.hpp | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/boost/process/detail/posix/executor.hpp b/boost/process/detail/posix/executor.hpp
-index 1390a58..8b86ed1 100644
---- a/boost/process/detail/posix/executor.hpp
-+++ b/boost/process/detail/posix/executor.hpp
-@@ -282,7 +282,10 @@ class executor
- set_error(std::error_code(err, std::system_category()), "Error read pipe");
- }
- if (count == 0)
-+ {
-+ ::close(source);
- return ;
-+ }
-
- std::error_code ec(data[0], std::system_category());
- std::string msg(data[1], ' ');
---
-2.7.4
-
diff --git a/meta-openbmc-mods/meta-common/recipes-support/boost/boost_%.bbappend b/meta-openbmc-mods/meta-common/recipes-support/boost/boost_%.bbappend
deleted file mode 100644
index f85e30b1f..000000000
--- a/meta-openbmc-mods/meta-common/recipes-support/boost/boost_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://0001-Fix-Issue-62.patch"