summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-wht
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-03-09 01:14:22 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-03-09 02:20:11 +0300
commit0cfc19e6565d8e3a1aa563c59edb347f9128026f (patch)
tree7146561723137e206a983483b06466d7ab5a9e2a /meta-openbmc-mods/meta-wht
parent930df2e58b9725756edbccf99fd4979026fc28fd (diff)
downloadopenbmc-0cfc19e6565d8e3a1aa563c59edb347f9128026f.tar.xz
Update to internal 0.35
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-wht')
-rw-r--r--meta-openbmc-mods/meta-wht/conf/bblayers.conf.sample8
-rw-r--r--meta-openbmc-mods/meta-wht/conf/layer.conf4
-rw-r--r--meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0001-Filter-memory-thermtrip-events-based-on-DIMM-status.patch42
-rw-r--r--meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0002-Add-a-workaround-for-spurious-CPU-errors.patch14
4 files changed, 42 insertions, 26 deletions
diff --git a/meta-openbmc-mods/meta-wht/conf/bblayers.conf.sample b/meta-openbmc-mods/meta-wht/conf/bblayers.conf.sample
index 3fe594301..f76660ab9 100644
--- a/meta-openbmc-mods/meta-wht/conf/bblayers.conf.sample
+++ b/meta-openbmc-mods/meta-wht/conf/bblayers.conf.sample
@@ -1,12 +1,12 @@
# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
-LCONF_VERSION = "12"
+LCONF_VERSION = "13"
BBPATH = "${TOPDIR}"
BBFILES ?= ""
-# meta-intel has a config file that needs to be overridden
-BBMASK = "/meta-intel/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb"
+# meta-intel-openbmc has a config file that needs to be overridden
+BBMASK = "/meta-intel-openbmc/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ipmb"
BBLAYERS ?= " \
##OEROOT##/meta \
@@ -19,7 +19,7 @@ BBLAYERS ?= " \
##OEROOT##/meta-aspeed \
##OEROOT##/meta-x86 \
##OEROOT##/meta-openbmc-mods \
- ##OEROOT##/meta-intel \
+ ##OEROOT##/meta-intel-openbmc \
##OEROOT##/meta-openbmc-mods/meta-common \
##OEROOT##/meta-openbmc-mods/meta-common-small \
##OEROOT##/meta-openbmc-mods/meta-ast2500 \
diff --git a/meta-openbmc-mods/meta-wht/conf/layer.conf b/meta-openbmc-mods/meta-wht/conf/layer.conf
index 7daf9ddc8..4ce9453f7 100644
--- a/meta-openbmc-mods/meta-wht/conf/layer.conf
+++ b/meta-openbmc-mods/meta-wht/conf/layer.conf
@@ -7,8 +7,8 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "wht"
-BBFILE_PATTERN_wht = ""
-BBFILE_PRIORITY_wht = "7"
+BBFILE_PATTERN_wht = "^${LAYERDIR}/"
+BBFILE_PRIORITY_wht = "11"
LAYERSERIES_COMPAT_wht = "dunfell gatesgarth"
PRODUCT_GENERATION = "wht"
diff --git a/meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0001-Filter-memory-thermtrip-events-based-on-DIMM-status.patch b/meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0001-Filter-memory-thermtrip-events-based-on-DIMM-status.patch
index 30859d1a4..140724ca9 100644
--- a/meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0001-Filter-memory-thermtrip-events-based-on-DIMM-status.patch
+++ b/meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0001-Filter-memory-thermtrip-events-based-on-DIMM-status.patch
@@ -1,7 +1,7 @@
-From 0253fd1d68d6a42c95c425b1a61fa2d53b2b2469 Mon Sep 17 00:00:00 2001
+From c09e608da2f63eed5b73891d5c032b646d8e81eb Mon Sep 17 00:00:00 2001
From: "Jason M. Bills" <jason.m.bills@intel.com>
Date: Wed, 22 Jul 2020 14:30:04 -0700
-Subject: [PATCH] Filter memory thermtrip events based on DIMM status
+Subject: [PATCH 1/2] Filter memory thermtrip events based on DIMM status
There is a race-condition on shutdown that makes it difficult to
differentiate between a normal shutdown and a memory thermtrip
@@ -22,22 +22,22 @@ that the memory thermtrip event is logged.
Change-Id: I9c38b41db30046499297ee24cc3a2790920b19d3
Signed-off-by: Jason M. Bills <jason.m.bills@intel.com>
---
- src/host_error_monitor.cpp | 77 +++++++++++++++++++++++++++++++++++++-
- 1 file changed, 75 insertions(+), 2 deletions(-)
+ src/host_error_monitor.cpp | 81 ++++++++++++++++++++++++++++++++++++--
+ 1 file changed, 77 insertions(+), 4 deletions(-)
diff --git a/src/host_error_monitor.cpp b/src/host_error_monitor.cpp
-index 1c6a2e70d..aa4a9b672 100644
+index d52a5dc6a..77d065fa3 100644
--- a/src/host_error_monitor.cpp
+++ b/src/host_error_monitor.cpp
-@@ -17,6 +17,7 @@
- #include <systemd/sd-journal.h>
-
+@@ -19,6 +19,7 @@
+ #include <boost/asio/io_service.hpp>
#include <boost/asio/posix/stream_descriptor.hpp>
+ #include <boost/asio/steady_timer.hpp>
+#include <boost/container/flat_set.hpp>
#include <gpiod.hpp>
#include <sdbusplus/asio/object_server.hpp>
-@@ -36,6 +37,9 @@ static std::shared_ptr<sdbusplus::asio::dbus_interface> associationCATAssert;
+@@ -38,6 +39,9 @@ static std::shared_ptr<sdbusplus::asio::dbus_interface> associationCATAssert;
static const constexpr char* rootPath = "/xyz/openbmc_project/CallbackManager";
@@ -47,7 +47,7 @@ index 1c6a2e70d..aa4a9b672 100644
static bool hostOff = true;
static size_t caterrTimeoutMs = 2000;
-@@ -258,6 +262,67 @@ static void initializeHostState()
+@@ -274,6 +278,67 @@ static void initializeHostState()
"xyz.openbmc_project.State.Host", "CurrentHostState");
}
@@ -115,7 +115,7 @@ index 1c6a2e70d..aa4a9b672 100644
static std::shared_ptr<sdbusplus::bus::match::match> startHostStateMonitor()
{
return std::make_shared<sdbusplus::bus::match::match>(
-@@ -826,7 +891,9 @@ static void cpu1MemtripHandler()
+@@ -851,7 +916,9 @@ static void cpu1MemtripHandler()
bool cpu1Memtrip =
gpioLineEvent.event_type == gpiod::line_event::FALLING_EDGE;
@@ -126,7 +126,7 @@ index 1c6a2e70d..aa4a9b672 100644
{
memThermTripLog(1);
}
-@@ -886,7 +953,9 @@ static void cpu2MemtripHandler()
+@@ -911,7 +978,9 @@ static void cpu2MemtripHandler()
bool cpu2Memtrip =
gpioLineEvent.event_type == gpiod::line_event::FALLING_EDGE;
@@ -137,7 +137,23 @@ index 1c6a2e70d..aa4a9b672 100644
{
memThermTripLog(2);
}
-@@ -1605,6 +1674,10 @@ int main(int argc, char* argv[])
+@@ -1521,13 +1590,13 @@ static void initializeErrorState()
+ }
+
+ // Handle CPU1_MEM_THERM_EVENT (CPU1 DIMM Thermal trip) if it's asserted now
+- if (cpu1MemtripLine.get_value() == 0)
++ if ((cpu1MemtripLine.get_value() == 0) && !cpu1CriticalDIMMs.empty())
+ {
+ memThermTripLog(1);
+ }
+
+ // Handle CPU2_MEM_THERM_EVENT (CPU2 DIMM Thermal trip) if it's asserted now
+- if (cpu2MemtripLine.get_value() == 0)
++ if ((cpu2MemtripLine.get_value() == 0) && !cpu2CriticalDIMMs.empty())
+ {
+ memThermTripLog(2);
+ }
+@@ -1639,6 +1708,10 @@ int main(int argc, char* argv[])
std::shared_ptr<sdbusplus::bus::match::match> hostStateMonitor =
host_error_monitor::startHostStateMonitor();
diff --git a/meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0002-Add-a-workaround-for-spurious-CPU-errors.patch b/meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0002-Add-a-workaround-for-spurious-CPU-errors.patch
index 2a573311f..1f1efea69 100644
--- a/meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0002-Add-a-workaround-for-spurious-CPU-errors.patch
+++ b/meta-openbmc-mods/meta-wht/recipes-core/host-error-monitor/host-error-monitor/0002-Add-a-workaround-for-spurious-CPU-errors.patch
@@ -1,7 +1,7 @@
-From d0e4130b2d1e0e44efc8fd6e180487853625edd6 Mon Sep 17 00:00:00 2001
+From d7909c8924cf3619bffd52e5f352f175c1cf5033 Mon Sep 17 00:00:00 2001
From: "Jason M. Bills" <jason.m.bills@intel.com>
Date: Mon, 17 Aug 2020 15:52:22 -0700
-Subject: [PATCH] Add a workaround for spurious CPU errors
+Subject: [PATCH 2/2] Add a workaround for spurious CPU errors
There is a possible issue where GPIO event interrupts are getting
missed causing false errors to be logged.
@@ -20,10 +20,10 @@ Signed-off-by: Jason M. Bills <jason.m.bills@intel.com>
1 file changed, 77 insertions(+)
diff --git a/src/host_error_monitor.cpp b/src/host_error_monitor.cpp
-index ca089f70d..fd453ccdc 100644
+index 77d065fa3..d026ab90d 100644
--- a/src/host_error_monitor.cpp
+++ b/src/host_error_monitor.cpp
-@@ -797,6 +797,18 @@ static void caterrAssertHandler()
+@@ -806,6 +806,18 @@ static void caterrAssertHandler()
}
return;
}
@@ -42,7 +42,7 @@ index ca089f70d..fd453ccdc 100644
std::cerr << "CATERR asserted for " << std::to_string(caterrTimeoutMs)
<< " ms\n";
beep(beepCPUIERR);
-@@ -1270,6 +1282,48 @@ static void errXAssertHandler(const int errPin,
+@@ -1288,6 +1300,48 @@ static void errXAssertHandler(const int errPin,
}
return;
}
@@ -91,7 +91,7 @@ index ca089f70d..fd453ccdc 100644
std::cerr << "ERR" << std::to_string(errPin) << " asserted for "
<< std::to_string(errTimeoutMs) << " ms\n";
if (errPinCPUs.count())
-@@ -1379,6 +1433,18 @@ static void err2AssertHandler()
+@@ -1397,6 +1451,18 @@ static void err2AssertHandler()
}
return;
}
@@ -110,7 +110,7 @@ index ca089f70d..fd453ccdc 100644
conn->async_method_call(
[](boost::system::error_code ec,
const std::variant<bool>& property) {
-@@ -1447,6 +1513,17 @@ static void smiAssertHandler()
+@@ -1465,6 +1531,17 @@ static void smiAssertHandler()
}
return;
}