summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-filesystems
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-20 16:15:15 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-20 16:15:22 +0300
commit90ca747aa04f375af7ff86462a52028245b174b9 (patch)
treefb660879f07363805138d821882c4092ac47c047 /meta-openembedded/meta-filesystems
parent0b251f46569493f7a028b31031e50316dd584299 (diff)
downloadopenbmc-90ca747aa04f375af7ff86462a52028245b174b9.tar.xz
meta-openembedded: subtree update: c95842cdca..509d40153d
Andreas Müller (13): xfce4-whiskermenu-plugin: upgrade 2.3.2 -> 2.3.3 xfmpc: upgrade 0.2.3 -> 0.3.0 xfce4-cpugraph-plugin: upgrade 1.0.5 -> 1.1.0 xfce4-terminal: upgrase 0.8.7.4 -> 0.8.8 gtksourceview3: upgrade 3.24.10 -> 3.24.11 mousepad: move to gtk3 mousepad: upgrade 0.4.1 -> 0.4.2 ristretto: upgrade 0.8.4 -> 0.10.0 catfish: upgrade 1.4.7 -> 1.4.8 xfce4-datetime-plugin: upgrade 0.7.1 -> 0.8.0 xfce4-places-plugin: 1.8.0 -> 1.8.1 xfce4-pulseaudio-plugin: upgrade 0.4.1 -> 0.4.2 parole: upgrade 1.0.2 -> 1.0.4 Brad Bishop (1): cli11: Remove dev pkg dep to main pkg Kai Kang (1): packagegroup-tools-bluetooth: correct RDEPENDS Khem Raj (8): libopus: Limit forcing ARM mode ISA to v5 only mime-construct,libextutils-parsexs-perl: add runtime dependency on perl webmin: Add perl to rdeps for modules hplip: Add python to rdeps klibc: Disable bcmp builtin for clang on glibc as well python3-blivet: Add python3 to rdeps grubby: Add bash to rdeps ufs-tool: Do not force static linking Martin Jansa (10): nodejs: fix QA error about /usr/bin/python dependency iotop: add runtime dependency on python-core freeradius: add runtime dependency on perl scsirastools: add runtime dependency on bash libcec: add runtime dependency on python3-core dnf-plugin-tui: add runtime dependency on bash edac-utils: add runtime dependency on perl lmsensors: add runtime dependency on bash libdbi-perl: add runtime dependency on perl scsirastools: add runtime dependency on bash II Piotr Tworek (4): telepathy-glib: Update to version 0.24.1 telepathy-glib: Enable vala bindings gnome-themes-standard: Update to version 3.28 libgdata: Update to version 0.17.10. Slater, Joseph (1): php: zlib and zip support Yuan Chao (3): xfsprogs: upgrade 5.1.0 -> 5.2.0 xfsdump: fix error to work with xfsprogs 5.2.0 python-pymongo: upgrade 3.8.0 -> 3.9.0 Change-Id: I9450310b0c5abd766ecd0ee21c9338159b36e940 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-filesystems')
-rw-r--r--meta-openembedded/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb5
-rw-r--r--meta-openembedded/meta-filesystems/recipes-utils/xfsdump/files/work-with-new-version-of-xfsprogs.patch28
-rw-r--r--meta-openembedded/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.8.bb1
-rw-r--r--meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb (renamed from meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.1.0.bb)4
4 files changed, 35 insertions, 3 deletions
diff --git a/meta-openembedded/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb b/meta-openembedded/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
index e074b5197..208ac3c58 100644
--- a/meta-openembedded/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
+++ b/meta-openembedded/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
@@ -12,8 +12,11 @@ SRC_URI = "git://github.com/westerndigitalcorporation/ufs-tool.git;protocol=git;
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}""
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" CFLAGS="${CFLAGS}""
+do_configure() {
+ sed -i -e "s|-static$||g" ${S}/Makefile
+}
do_install() {
install -d ${D}${bindir}/
install -c -m 755 ${S}/ufs-tool ${D}${bindir}/
diff --git a/meta-openembedded/meta-filesystems/recipes-utils/xfsdump/files/work-with-new-version-of-xfsprogs.patch b/meta-openembedded/meta-filesystems/recipes-utils/xfsdump/files/work-with-new-version-of-xfsprogs.patch
new file mode 100644
index 000000000..4ce23d717
--- /dev/null
+++ b/meta-openembedded/meta-filesystems/recipes-utils/xfsdump/files/work-with-new-version-of-xfsprogs.patch
@@ -0,0 +1,28 @@
+Make it work with xfsprogs 5.2.0.
+
+"xfs_fsop_geom_v1_t" has changed to "struct xfs_fsop_geom_v1"
+in xfsprogs since version 5.2.0.
+
+Upstream-Status: Pending
+
+Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com>
+---
+ common/fs.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/common/fs.c b/common/fs.c
+index 60cf0fd..2cc7031 100644
+--- a/common/fs.c
++++ b/common/fs.c
+@@ -204,7 +204,7 @@ fs_mounted( char *typs, char *chrs, char *mnts, uuid_t *idp )
+ int
+ fs_getid( char *mnts, uuid_t *idb )
+ {
+- xfs_fsop_geom_v1_t geo;
++ struct xfs_fsop_geom_v1 geo;
+ int fd;
+
+ fd = open( mnts, O_RDONLY );
+--
+2.7.4
+
diff --git a/meta-openembedded/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.8.bb b/meta-openembedded/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.8.bb
index 54ab30cbb..0421aa06d 100644
--- a/meta-openembedded/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.8.bb
+++ b/meta-openembedded/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.8.bb
@@ -12,6 +12,7 @@ DEPENDS = "xfsprogs attr"
SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsdump/${BP}.tar.xz \
file://remove-install-as-user.patch \
+ file://work-with-new-version-of-xfsprogs.patch \
"
SRC_URI[md5sum] = "84d3bc287b4a2bb5d16b2320a47049a7"
SRC_URI[sha256sum] = "ed14e67ae5b273c2698e767b43a46f033d361e540fe13feaaf9b110ee0edc585"
diff --git a/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.1.0.bb b/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb
index 0130fd227..10d1b70d5 100644
--- a/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.1.0.bb
+++ b/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb
@@ -12,8 +12,8 @@ SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \
file://0001-Check-for-MAP_SYNC-in-sys-mman.h.patch \
file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \
"
-SRC_URI[md5sum] = "7199b7aaf088d82fc8a1660ffeb63626"
-SRC_URI[sha256sum] = "ca8b4e73dfc5b6227bb6d4e73d019035a1975b83ea41e218cdff15058a9f6c45"
+SRC_URI[md5sum] = "e38032818aa3b1ef224a69b6184fc12a"
+SRC_URI[sha256sum] = "e41cdaa43d92b38c8a12ce9cb612ab911ba0e019c2e0762c494a8a601f533fd6"
inherit autotools-brokensep