summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-filesystems
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:17:45 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:17:50 +0300
commita891d150c6a7455ddbb797bdc472f45fd5f36008 (patch)
tree675a1c6f76065884b0c99b5a6056c79de44ef083 /meta-openembedded/meta-filesystems
parent4bfffde7b5edeee761d32b174386bd1e1e28fab9 (diff)
downloadopenbmc-a891d150c6a7455ddbb797bdc472f45fd5f36008.tar.xz
meta-openembedded: subtree update:ce51958eca..a2928764c2
Adrian Bunk (3): python3-cmd2: Remove PNBLACKLIST php: Remove no longer needed CFLAGS_append_aarch64 php: Move more into php.inc after php5 removal Alistair Francis (4): python3-requests-future: Initial commit of 0.9.5 python3-xmlrunner: Initial commit of 1.7.7 python3-fasteners: Initial commit of 0.15 python3-python-vlc: Initial commit of 3.0.7110 Anuj Mittal (3): python3-defusedxml: add recipe python-networkx: upgrade 2.1 -> 2.2 python3-networkx: add recipe Khem Raj (9): php: Turn PCRE JIT off for riscv redis: Fix build with clang/x86 android-tools: Recognise i686 for HOST_ARCH netdata: Update to 1.17.0 and fix build with clang/x86 safec: Define _GNU_SOURCE safec: Upgrade to 3.5 release openocd: Add --disable-werror always breakpad: Update dont-clobber-rsp patch to latest gparted: add to deps instead of overwriting Martin Jansa (3): remmina: add distro_features_check for GTK3DISTROFEATURES ceres-solver: fix the paths in .cmake files ceres-solver: add PACKAGECONFIG for suitesparse and lapack Naveen Saini (1): pm-graph: upgrade 5.3 -> 5.5 Oleksandr Kravchuk (1): analyze-suspend: update to 5.5 Peter Kjellerstedt (1): lvm2/libdevmapper: Make it build for native Randy MacLeod (1): poppler: update from 0.79.0 to 0.80.0 Slater, Joseph (1): openhpi: control snmp-bc ptest generation Stefan Agner (1): fuse3: add libfuse3 recipe Trevor Gamblin (1): gvfs: upgrade 1.40.2 -> 1.41.2 for CVE fixes Yi Zhao (2): php: fix module path in mod_php.conf apache-websocket: fix module path Yuan Chao (2): python-atomicwrites: new recipe python-pytest: fix runtime error Zang Ruochen (1): python-certifi: upgrade 2019.6.16 -> 2019.9.11 Change-Id: Iba065b25686a1ac22d647226d9ea0c61c5b4578f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-filesystems')
-rw-r--r--meta-openembedded/meta-filesystems/recipes-support/fuse/fuse3_3.6.2.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse3_3.6.2.bb b/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse3_3.6.2.bb
new file mode 100644
index 000000000..e65eb08e2
--- /dev/null
+++ b/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse3_3.6.2.bb
@@ -0,0 +1,48 @@
+SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
+DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
+ programs to export a virtual filesystem to the Linux kernel. FUSE \
+ also aims to provide a secure method for non privileged users to \
+ create and mount their own filesystem implementations. \
+ "
+HOMEPAGE = "https://github.com/libfuse/libfuse"
+SECTION = "libs"
+LICENSE = "GPLv2 & LGPLv2"
+LIC_FILES_CHKSUM = "file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
+ file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66"
+
+SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.xz \
+"
+SRC_URI[md5sum] = "1798945aa69434286723b9999a141c7a"
+SRC_URI[sha256sum] = "f45869427575e1e59ab743a67deb57addbf2cb8f9ce431199dbd40ddab71f281"
+
+S = "${WORKDIR}/fuse-${PV}"
+
+UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
+UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
+
+inherit meson pkgconfig
+
+DEPENDS = "udev"
+
+PACKAGES =+ "fuse3-utils"
+
+RPROVIDES_${PN}-dbg += "fuse3-utils-dbg"
+
+RRECOMMENDS_${PN}_class-target = "kernel-module-fuse fuse3-utils"
+
+FILES_${PN} += "${libdir}/libfuse3.so.*"
+FILES_${PN}-dev += "${libdir}/libfuse3*.la"
+
+EXTRA_OEMESON += " \
+ -Dexamples=false \
+"
+
+# Forbid auto-renaming to libfuse3-utils
+FILES_fuse3-utils = "${bindir} ${base_sbindir}"
+DEBIAN_NOAUTONAME_fuse3-utils = "1"
+DEBIAN_NOAUTONAME_${PN}-dbg = "1"
+
+do_install_append() {
+ rm -rf ${D}${base_prefix}/dev
+}