summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-gnome/gdm/gdm_3.36.3.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-10-04 22:42:48 +0300
committerGitHub <noreply@github.com>2021-10-04 22:42:48 +0300
commit0c9e31989c615598b5d042ffab385606660c93c0 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-openembedded/meta-gnome/recipes-gnome/gdm/gdm_3.36.3.bb
parent04cd92067d2481643df5010cb39b2134b648cf4d (diff)
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
downloadopenbmc-0c9e31989c615598b5d042ffab385606660c93c0.tar.xz
Merge pull request #72 from Intel-BMC/update2021-0.751-0.75
Update
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-gnome/gdm/gdm_3.36.3.bb')
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/gdm/gdm_3.36.3.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/gdm/gdm_3.36.3.bb b/meta-openembedded/meta-gnome/recipes-gnome/gdm/gdm_3.36.3.bb
index fb0b77bf4..74e2bd677 100644
--- a/meta-openembedded/meta-gnome/recipes-gnome/gdm/gdm_3.36.3.bb
+++ b/meta-openembedded/meta-gnome/recipes-gnome/gdm/gdm_3.36.3.bb
@@ -23,33 +23,33 @@ EXTRA_OECONF = " \
--with-pam-mod-dir=${base_libdir}/security \
"
-do_install_append() {
+do_install:append() {
rm -rf ${D}/run ${D}${localstatedir}/run
}
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --no-create-home --home ${localstatedir}/lib/gdm --user-group gdm"
+USERADD_PARAM:${PN} = "--system --no-create-home --home ${localstatedir}/lib/gdm --user-group gdm"
-SYSTEMD_SERVICE_${PN} = "${BPN}.service"
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
# Some gnome components - as gnome-panel and gnome-shell (!!) - require gdm
# components. To allow gnome-images using different display-manager, split them
# out into a seperate package.
PACKAGE_BEFORE_PN = "${PN}-base"
-FILES_${PN}-base = " \
+FILES:${PN}-base = " \
${datadir}/glib-2.0 \
${datadir}/gnome-session \
${libdir}/lib*${SOLIBS} \
${libdir}/girepository-1.0 \
"
-CONFFILES_${PN} += "${sysconfdir}/gdm/custom.conf"
-FILES_${PN} += " \
+CONFFILES:${PN} += "${sysconfdir}/gdm/custom.conf"
+FILES:${PN} += " \
${datadir}/dconf \
${base_libdir}/security/pam_gdm.so \
${localstatedir} \
${systemd_unitdir} \
"
-RDEPENDS_${PN} += "${PN}-base"
+RDEPENDS:${PN} += "${PN}-base"