summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.10.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-06-06 01:59:17 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-06 02:11:09 +0300
commiteafcbb8a73edfad32d50070982300335b553e28e (patch)
treea5f04eb03300cc0b1a959c024e40720f6e8252bd /meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.10.bb
parentccb96fccef02f3812b232a8a1d105925d1ea2458 (diff)
downloadopenbmc-eafcbb8a73edfad32d50070982300335b553e28e.tar.xz
meta-openembedded: subtree update:713e70bd25..5caca0f7bd
Andreas Müller (1): fluidsynth: upgrade 2.1.2 -> 2.1.3 Domarys Correa (6): python3-pytest: Update 5.3.5 -> 5.4.2 python3-pytest-html: Update 1.6 -> 2.1.1 python3-pytest-metadata: Update 1.8.0 -> 1.9.0 python3-pytest-asyncio: Update 0.10.0 -> 0.12.0 python3-pyudev: Update 0.21.0 -> 0.22.0 python3-pyyaml: Update 5.3 -> 5.3.1 Hongxu Jia (1): multipath-tools: fix compiling parallel issue Kai Kang (1): plymouth: disable systemd-integration for sysvinit Khem Raj (1): dfu-util-native: Remove DEPLOY_DIR_TOOLS from sstate-outputdirs Konrad Weihmann (14): pugixml: fix typo for homepage distuils-extra: fix typo for DESCRIPTION brotli: fix typo for DESCRIPTION wxwidgets: fix typo for DESCRIPTION passwdqc: remove double modify operation zbar: fix typo for DESCRIPTION sound-theme-freedesktop: remove double depends python3-cmd2: remove double colorama in RDEPENDS python3-smbus2: remove duplicate RDEPENDS settings python3-twisted: remove double var modification spawn-fcgi: fix typo in SUMMARY physfs: fix typo for HOMEPAGE rest: fix typo for HOMEPAGE proftpd: Fix typo for SRC_URI[md5sum] Leon Anavi (4): python3-click: Upgrade 7.0 -> 7.1.2 python3-dbussy: Upgrade 1.2.1 -> 1.3 python3-imageio: Upgrade 2.6.0 -> 2.8.0 python3-colorama: Upgrade 0.4.1 -> 0.4.3 Maciej Pijanowski (1): qpdf: fix typo in RDEPENDS Martin Jansa (1): irssi: package libirc_proxy.a in PN-staticdev Michael Haener (1): cockpit: 219 -> 220 Patrick Williams (1): net-snmp: refresh patches Pierre-Jean Texier (2): libuv: upgrade 1.36.0 -> 1.38.0 uftp: upgrade 4.10.2 -> 5.0 Robert P. J. Day (1): use weak assignments for PNBLACKLIST in recipe files Shlomi Vaknin (1): add python bitstring package Zang Ruochen (6): libgphoto2: upgrade 2.5.24 -> 2.5.25 rsyslog: upgrade 8.2002 -> 8.2004 mosquitto: upgrade 1.6.9 -> 1.6.10 snort: upgrade 2.9.15 -> 2.9.16 wireshark: upgrade 3.2.2 -> 3.2.4 cpuid: upgrade 20200211 -> 20200427 Zheng Ruoqin (5): nano: upgrade 4.9.2 -> 4.9.3 gsoap: upgrade 2.8.100 -> 2.8.103 logwatch: upgrade 7.5.1 -> 7.5.3 mcelog: upgrade 168 -> 170 libnet-dns-perl: upgrade 1.23 -> 1.24 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I697f91df13d9e8d8cb15620aeccd644cdfe53a43
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.10.bb')
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.10.bb87
1 files changed, 87 insertions, 0 deletions
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.10.bb b/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.10.bb
new file mode 100644
index 000000000..31b5f678d
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.10.bb
@@ -0,0 +1,87 @@
+SUMMARY = "Open source MQTT implementation"
+DESCRIPTION = "Mosquitto is an open source (Eclipse licensed) message broker \
+that implements the MQ Telemetry Transport protocol version 3.1, 3.1.1 and \
+5, providing both an MQTT broker and several command-line clients. MQTT \
+provides a lightweight method of carrying out messaging using a \
+publish/subscribe model. "
+HOMEPAGE = "http://mosquitto.org/"
+SECTION = "console/network"
+LICENSE = "EPL-1.0 | EDL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=62ddc846179e908dc0c8efec4a42ef20 \
+ file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \
+ file://epl-v10;md5=8d383c379e91d20ba18a52c3e7d3a979 \
+ file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \
+"
+DEPENDS = "uthash"
+
+SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \
+ file://mosquitto.init \
+ file://1571.patch \
+ file://install-protocol.patch \
+"
+
+SRC_URI[md5sum] = "960f963b81b7f93982d7511cd28082e5"
+SRC_URI[sha256sum] = "92d1807717f0f6d57d1ac1207ffdb952e8377e916c7b0bb4718f745239774232"
+
+inherit systemd update-rc.d useradd cmake
+
+PACKAGECONFIG ??= "ssl dlt websockets \
+ ${@bb.utils.filter('DISTRO_FEATURES','systemd', d)} \
+ "
+
+PACKAGECONFIG[dns-srv] = "-DWITH_SRV=ON,-DWITH_SRV=OFF,c-ares"
+PACKAGECONFIG[ssl] = "-DWITH_TLS=ON -DWITH_TLS_PSK=ON -DWITH_EC=ON,-DWITH_TLS=OFF -DWITH_TLS_PSK=OFF -DWITH_EC_OFF,openssl"
+PACKAGECONFIG[systemd] = "-DWITH_SYSTEMD=ON,-DWITH_SYSTEMD=OFF,systemd"
+PACKAGECONFIG[websockets] = "-DWITH_WEBSOCKETS=ON,-DWITH_WEBSOCKETS=OFF,libwebsockets"
+PACKAGECONFIG[dlt] = "-DWITH_DLT=ON,-DWITH_DLT=OFF,dlt-daemon"
+
+EXTRA_OECMAKE = " \
+ -DWITH_BUNDLED_DEPS=OFF \
+ -DWITH_ADNS=ON \
+"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${S}/service/systemd/mosquitto.service.notify ${D}${systemd_unitdir}/system/mosquitto.service
+
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/mosquitto.init ${D}${sysconfdir}/init.d/mosquitto
+ sed -i -e 's,@SBINDIR@,${sbindir},g' \
+ -e 's,@BASE_SBINDIR@,${base_sbindir},g' \
+ -e 's,@LOCALSTATEDIR@,${localstatedir},g' \
+ -e 's,@SYSCONFDIR@,${sysconfdir},g' \
+ ${D}${sysconfdir}/init.d/mosquitto
+}
+
+PACKAGES += "libmosquitto1 libmosquittopp1 ${PN}-clients"
+
+PACKAGE_BEFORE_PN = "${PN}-examples"
+
+FILES_${PN} = "${sbindir}/mosquitto \
+ ${bindir}/mosquitto_passwd \
+ ${sysconfdir}/mosquitto \
+ ${sysconfdir}/init.d \
+ ${systemd_unitdir}/system/mosquitto.service \
+"
+
+CONFFILES_${PN} += "${sysconfdir}/mosquitto/mosquitto.conf"
+
+FILES_libmosquitto1 = "${libdir}/libmosquitto.so.*"
+
+FILES_libmosquittopp1 = "${libdir}/libmosquittopp.so.*"
+
+FILES_${PN}-clients = "${bindir}/mosquitto_pub \
+ ${bindir}/mosquitto_sub \
+ ${bindir}/mosquitto_rr \
+"
+
+FILES_${PN}-examples = "${sysconfdir}/mosquitto/*.example"
+
+SYSTEMD_SERVICE_${PN} = "mosquitto.service"
+
+INITSCRIPT_NAME = "mosquitto"
+INITSCRIPT_PARAMS = "defaults 30"
+
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--system --no-create-home --shell /bin/false \
+ --user-group mosquitto"