summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-support/ntopng/ntopng_5.0.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-11-05 18:45:06 +0300
committerGitHub <noreply@github.com>2021-11-05 18:45:06 +0300
commit4dac5fcd49b5e2de1074f1363775ec0f19041072 (patch)
tree5aadf91080299b1583caed86a31da368dfcda2da /meta-openembedded/meta-networking/recipes-support/ntopng/ntopng_5.0.bb
parent0c9e31989c615598b5d042ffab385606660c93c0 (diff)
parent61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (diff)
downloadopenbmc-4dac5fcd49b5e2de1074f1363775ec0f19041072.tar.xz
Merge pull request #74 from Intel-BMC/update2021-0.771-0.77
Update
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-support/ntopng/ntopng_5.0.bb')
-rw-r--r--meta-openembedded/meta-networking/recipes-support/ntopng/ntopng_5.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-openembedded/meta-networking/recipes-support/ntopng/ntopng_5.0.bb b/meta-openembedded/meta-networking/recipes-support/ntopng/ntopng_5.0.bb
new file mode 100644
index 000000000..89107430e
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-support/ntopng/ntopng_5.0.bb
@@ -0,0 +1,49 @@
+SUMMARY = "Web-based Traffic and Security Network Traffic Monitoring"
+DESCRIPTION = "ntopng is a web-based network traffic monitoring application \
+released under GPLv3. It is the new incarnation of the original \
+ntop written in 1998, and now revamped in terms of performance, \
+usability, and features."
+
+SECTION = "console/network"
+
+DEPENDS = "curl libmaxminddb libpcap lua mariadb ndpi json-c rrdtool zeromq"
+RDEPENDS:${PN} = "bash redis"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRCREV = "85867090d92df4365c0af8d47f54ab3106117e59"
+SRC_URI = "git://github.com/ntop/ntopng.git;protocol=git;branch=5.0-stable \
+ file://0001-configure.seed-fix-configure-error.patch \
+ file://0001-configure.seed-fix-host-contamination.patch \
+ file://0001-Makefile.in-don-t-use-the-internal-lua.patch \
+ file://0001-autogen.sh-generate-configure.ac-only.patch \
+ file://0001-configure.seed-not-check-clang-on-host.patch \
+ file://ntopng.service \
+"
+
+S = "${WORKDIR}/git"
+
+# don't use the lua under thirdparty as it supports cross compiling badly
+export LUA_LIB = "${STAGING_LIBDIR}/liblua.a"
+
+LDFLAGS:append:mipsarch = " -latomic"
+LDFLAGS:append:powerpc = " -latomic"
+LDFLAGS:append:riscv32 = " -latomic"
+inherit autotools-brokensep gettext systemd
+
+do_install:append() {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/ntopng.service ${D}${systemd_unitdir}/system
+}
+
+FILES:${PN} += "\
+ ${systemd_unitdir}/system/ntopng.service"
+
+FILES:${PN}-doc += "\
+ /usr/man/man8/ntopng.8"
+
+do_configure:prepend() {
+ ${S}/autogen.sh
+}
+
+SYSTEMD_SERVICE:${PN} = "ntopng.service"