summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.2.6.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-07 16:34:48 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-07 16:34:54 +0300
commit4fe7a1353f8f7f96c7407caa3352fa50fcce5aa3 (patch)
treee1e898e098bec469e02e357983dae7436a072235 /meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.2.6.bb
parent00e122a7b3a839f5ce8b819cb1bfe92cf3781eda (diff)
downloadopenbmc-4fe7a1353f8f7f96c7407caa3352fa50fcce5aa3.tar.xz
meta-openembedded: subtree update:e6d76b05a7..01d539b324
Adrian Ratiu (1): renderdoc: add x11 to REQUIRED_DISTRO_FEATURES Callaghan, Dan (2): firewalld: update to 0.7.1 strongswan: install dev headers George McCollister (1): wireshark: fix qt5 build Jean-Marie LEMETAYER (1): python-toml: add recipes for python2 and python3 Khem Raj (1): xscreensaver: Remove xserver-nodm-init rdep Maciej Pijanowski (1): smem: package smemcap separately Ovidiu Panait (1): kea: Disable parallel install Peiran Hong (1): zabbix: upgrade 3.0.9 -> 4.2.6 Randy MacLeod (1): libteam: update from 1.28 to 1.29 Trevor Gamblin (2): php: fix CVE-2019-6978 gd: fix CVE-2019-6978 Change-Id: I2c308ff46213876c1d74f42b5d9f9e52946bbf02 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.2.6.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.2.6.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.2.6.bb b/meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.2.6.bb
new file mode 100644
index 000000000..33c0a82b8
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/zabbix/zabbix_4.2.6.bb
@@ -0,0 +1,79 @@
+SUMMARY = "Open-source monitoring solution for your IT infrastructure"
+DESCRIPTION = "\
+ZABBIX is software that monitors numerous parameters of a network and the \
+health and integrity of servers. ZABBIX uses a flexible notification \
+mechanism that allows users to configure e-mail based alerts for virtually \
+any event. This allows a fast reaction to server problems. ZABBIX offers \
+excellent reporting and data visualisation features based on the stored \
+data. This makes ZABBIX ideal for capacity planning. \
+\
+ZABBIX supports both polling and trapping. All ZABBIX reports and \
+statistics, as well as configuration parameters are accessed through a \
+web-based front end. A web-based front end ensures that the status of \
+your network and the health of your servers can be assessed from any \
+location. Properly configured, ZABBIX can play an important role in \
+monitoring IT infrastructure. This is equally true for small \
+organisations with a few servers and for large companies with a \
+multitude of servers."
+HOMEPAGE = "http://www.zabbix.com/"
+SECTION = "Applications/Internet"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
+DEPENDS = "libevent libpcre openldap virtual/libiconv zlib"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRC_URI = "http://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${BPN}-${PV}.tar.gz \
+ file://0001-Fix-configure.ac.patch \
+ file://zabbix-agent.service \
+"
+
+SRC_URI[md5sum] = "6cd55cd743d416d9ffbf2e6fdee680ee"
+SRC_URI[sha256sum] = "646b1f29a768e3123a00a9afadf382b4d0dfd54e20fb31023f0d6da066da0864"
+
+inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "zabbix-agent.service"
+SYSTEMD_AUTO_ENABLE = "enable"
+
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "-r zabbix"
+USERADD_PARAM_${PN} = "-r -g zabbix -d /var/lib/zabbix \
+ -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \
+"
+
+KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
+
+EXTRA_OECONF = " \
+ --enable-dependency-tracking \
+ --enable-agent \
+ --enable-ipv6 \
+ --with-net-snmp \
+ --with-ldap=${STAGING_EXECPREFIXDIR} \
+ --with-jabber \
+ --with-unixodbc \
+ --with-ssh2 \
+ --with-sqlite3 \
+ --with-zlib \
+ --with-libpthread \
+ --with-libevent \
+ --with-libpcre \
+"
+CFLAGS_append = " -lldap -llber -pthread"
+
+do_configure_prepend() {
+ export KERNEL_VERSION="${KERNEL_VERSION}"
+}
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
+ sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
+ fi
+}
+
+FILES_${PN} += "${libdir}"
+
+RDEPENDS_${PN} = "logrotate"