summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/pahole/pahole_1.22.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-11-04 00:19:32 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-11-04 00:19:32 +0300
commit901ced0812b458fdc599fe40b0a4233d422d6df9 (patch)
treeb0918e0606da0b1925b5fc9aba5e065e0a5a2f0e /meta-openembedded/meta-oe/recipes-devtools/pahole/pahole_1.22.bb
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
parent459d47e59bfb3f80542f17c7eb54ba1f6c1a44f3 (diff)
downloadopenbmc-901ced0812b458fdc599fe40b0a4233d422d6df9.tar.xz
Merge tag '0.77' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/pahole/pahole_1.22.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/pahole/pahole_1.22.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/pahole/pahole_1.22.bb b/meta-openembedded/meta-oe/recipes-devtools/pahole/pahole_1.22.bb
new file mode 100644
index 000000000..db7d88cdf
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/pahole/pahole_1.22.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Shows and manipulates data structure layout"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS = "elfutils zlib libbpf"
+
+COMPATIBLE_HOST = "(x86_64|i.86|aarch64).*-linux"
+
+SRCREV = "f02af2553ea58ae1186226af0d0ec835a248358f"
+SRC_URI = "git://git.kernel.org/pub/scm/devel/pahole/pahole.git \
+ file://0001-CMakeList.txt-make-python-optional.patch"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG[python3] = ",,python3-core,python3-core"
+
+EXTRA_OECMAKE = "-D__LIB=lib -DCMAKE_BUILD_TYPE=Release -DLIBBPF_EMBEDDED=OFF"
+
+FILES:${PN} = "${bindir}/pahole \
+ ${libdir}/libdwarves.so* \
+ ${libdir}/libdwarves_reorganize.so*"
+
+PACKAGES += "${PN}-extra"
+FILES:${PN}-extra = "${datadir} ${bindir} ${libdir}/libdwarves_emit.so*"
+RDEPENDS:${PN}-extra += "bash python3-core"
+
+BBCLASSEXTEND = "native nativesdk"